MiniSqlQuery.Core Namespace

Mini SQL Query Extensibility Documentation
MiniSqlQuery.Core Namespace
Namespaces ► MiniSqlQuery.Core
Mini SQL Query application interfaces and some basic implementations.
Declaration Syntax
C# Visual Basic Visual C++
namespace MiniSqlQuery.Core
Namespace MiniSqlQuery.Core
namespace MiniSqlQuery.Core
Types
All Types Classes Interfaces
Icon | Type | Description
 | ApplicationServices | The core services of the application (singleton).
 | BasicTextFindService | A simple text finding service. Currently supports forward only text matching.
 | CommandControlBuilder | Helper class for building controls out of ICommand objects.
 | CommandManager | Stores instances of commands by type.
 | ConnectionDefinition | Obsolete. Provides a defition of database connections by provider and name.
 | DatabaseMetaDataService | Creates a simplified view of the database schema for a given provider and connection string.
 | DbConnectionDefinition | Provides a defition of database connection by provider and name.
 | DbConnectionDefinitionList |
 | FindTextRequest | A class that encapsulates a "find text" request, storing the position
 | IApplicationServices | The core services of the application.
 | IApplicationSettings | An interface for the application settings.
 | ICommand | Represents a "command", typically a user action such as saving a file or executing a query.
 | IDatabaseInspector | An interface to the query windows database inspector.
 | IFindReplaceProvider | A control that allows its text to be "found" and optionally "replaced". The query editor is an obvious provider but other windows can also provide find/replace functionality by implementing this interface (tools, output windows etc).
 | IHostWindow | Core functions of the main MDI application host Form.
 | ImageResource | A strongly-typed resource class, for looking up localized strings, etc.
 | INavigatableDocument | An interface for a "document" that can be navigated with a cursor, e.g. position at line 1, column 4 etc.
 | IPlugIn | An interface for simple plugins for use in extending Mini SQL Query. Plugins are loaded from DLL's in the working directory matching the pattern "*.PlugIn.dll"
 | IPrintableContent | If implemented it signals that the class supports printing of the "contents" of the object.
 | IQueryEditor | The functions of the editing window.
 | ISupportCursorOffset | A "document" that supports reporting the position of it's cursor
 | ITextFindService | A text finding serice interface. A window can implement this interface and it will allow searching of its text.
 | PlugInComparer | Used for sorting plugins at load time.
 | PluginLoaderBase | A simple base class to use for implementing the IPlugIn interface.
 | PlugInUtility | Helper class for loading external plugins.
 | StringWriterWithEncoding |
 | Utility | Some basic helper functions.

PK Software (Paul Kohler)


ApplicationServices Class

ApplicationServices Class
Namespaces ► MiniSqlQuery.Core ► ApplicationServices
The core services of the application (singleton).
Declaration Syntax
C# Visual Basic Visual C++
public class ApplicationServices : IApplicationServices
Public Class ApplicationServices _
    Implements IApplicationServices
public ref class ApplicationServices : IApplicationServices
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplicationServices()()() |
 | Container | The Dependency Injection container.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | HostWindow | The application host window.
 | InitializePlugIns()()() | Initializes the plugins that have been loaded during application startup.
 | Instance | A reference to the singleton instance of the services for this application.
 | LoadPlugFromContainer(String) | Loads a plugin configured via the Container.
 | LoadPlugIn(IPlugIn) | Loads the plugIn (calling its LoadPlugIn(IApplicationServices) method) and adds it to the Plugins dictionary for access by other services.
 | MemberwiseClone()()() | (Inherited from Object.)
 | Plugins | A dictionary of the current plugins for this application.
 | Settings | The application settings instance.
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ApplicationServices

PK Software (Paul Kohler)

Assembly: MiniSqlQuery.Core (Module: MiniSqlQuery.Core) Version: 1.0.0.0 (1.0.0.0)


ApplicationServices Constructor

ApplicationServices Constructor
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► ApplicationServices()()()
Initializes a new instance of the ApplicationServices class.
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationServices()
Public Sub New
public:
ApplicationServices()


Container Property

Container Property
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► Container
The Dependency Injection container.
Declaration Syntax
C# Visual Basic Visual C++
public IWindsorContainer Container { get; }
Public ReadOnly Property Container As IWindsorContainer
public:
virtual property IWindsorContainer^ Container {
    IWindsorContainer^ get () sealed;
}


HostWindow Property

HostWindow Property
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► HostWindow
The application host window.
Declaration Syntax
C# Visual Basic Visual C++
public IHostWindow HostWindow { get; }
Public ReadOnly Property HostWindow As IHostWindow
public:
virtual property IHostWindow^ HostWindow {
    IHostWindow^ get () sealed;
}
Value
The host window - a Form.


InitializePlugIns Method

InitializePlugIns Method
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► InitializePlugIns()()()
Initializes the plugins that have been loaded during application startup.
Declaration Syntax
C# Visual Basic Visual C++
public void InitializePlugIns()
Public Sub InitializePlugIns
public:
virtual void InitializePlugIns() sealed


Instance Property

Instance Property
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► Instance
A reference to the singleton instance of the services for this application.
Declaration Syntax
C# Visual Basic Visual C++
public static IApplicationServices Instance { get; }
Public Shared ReadOnly Property Instance As IApplicationServices
public:
static property IApplicationServices^ Instance {
    IApplicationServices^ get ();
}
Value
The singleton instance of IApplicationServices.


LoadPlugFromContainer Method (plugInKeyName)

LoadPlugFromContainer Method (plugInKeyName)
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► LoadPlugFromContainer(String)
Loads a plugin configured via the Container.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadPlugFromContainer(
    string plugInKeyName
)
Public Sub LoadPlugFromContainer ( _
    plugInKeyName As String _
)
public:
void LoadPlugFromContainer(
    String^ plugInKeyName
)
Parameters
plugInKeyName (String)
The "key" of the service.


LoadPlugIn Method (plugIn)

LoadPlugIn Method (plugIn)
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► LoadPlugIn(IPlugIn)
Loads the plugIn (calling its LoadPlugIn(IApplicationServices) method) and adds it to the Plugins dictionary for access by other services.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadPlugIn(
    IPlugIn plugIn
)
Public Sub LoadPlugIn ( _
    plugIn As IPlugIn _
)
public:
virtual void LoadPlugIn(
    IPlugIn^ plugIn
) sealed
Parameters
plugIn (IPlugIn)
The plugin to load.
Exceptions
Exception | Condition
ArgumentNullException | If plugIn is null.


Plugins Property

Plugins Property
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► Plugins
A dictionary of the current plugins for this application.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<Type, IPlugIn> Plugins { get; }
Public ReadOnly Property Plugins As Dictionary(Of Type, IPlugIn)
public:
virtual property Dictionary<Type^, IPlugIn^>^ Plugins {
    Dictionary<Type^, IPlugIn^>^ get () sealed;
}
Value
A reference to the plugin dictionary.


Settings Property

Settings Property
Namespaces ► MiniSqlQuery.Core ► ApplicationServices ► Settings
The application settings instance.
Declaration Syntax
C# Visual Basic Visual C++
public IApplicationSettings Settings { get; }
Public ReadOnly Property Settings As IApplicationSettings
public:
virtual property IApplicationSettings^ Settings {
    IApplicationSettings^ get () sealed;
}
Value
A reference to the settings handler.


BasicTextFindService Class

BasicTextFindService Class
Namespaces ► MiniSqlQuery.Core ► BasicTextFindService
A simple text finding service. Currently supports forward only text matching.
Declaration Syntax
C# Visual Basic Visual C++
public class BasicTextFindService : ITextFindService
Public Class BasicTextFindService _
    Implements ITextFindService
public ref class BasicTextFindService : ITextFindService
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BasicTextFindService(IApplicationServices) | Creates a new text find service.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | FindNext(FindTextRequest) | Looks for the next match depending on the settings in the request.
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
BasicTextFindService


BasicTextFindService Constructor (applicationServices)

BasicTextFindService Constructor (applicationServices)
Namespaces ► MiniSqlQuery.Core ► BasicTextFindService ► BasicTextFindService(IApplicationServices)
Creates a new text find service.
Declaration Syntax
C# Visual Basic Visual C++
public BasicTextFindService(
    IApplicationServices applicationServices
)
Public Sub New ( _
    applicationServices As IApplicationServices _
)
public:
BasicTextFindService(
    IApplicationServices^ applicationServices
)
Parameters
applicationServices (IApplicationServices)
A reference to the application services.


FindNext Method (request)

FindNext Method (request)
Namespaces ► MiniSqlQuery.Core ► BasicTextFindService ► FindNext(FindTextRequest)
Looks for the next match depending on the settings in the request.
Declaration Syntax
C# Visual Basic Visual C++
public FindTextRequest FindNext(
    FindTextRequest request
)
Public Function FindNext ( _
    request As FindTextRequest _
) As FindTextRequest
public:
virtual FindTextRequest^ FindNext(
    FindTextRequest^ request
) sealed
Parameters
request (FindTextRequest)
The text find request.
Return Value
An updated request with the relevent values adjusted (namely position).


CommandControlBuilder Class

CommandControlBuilder Class
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder
Helper class for building controls out of ICommand objects.
Declaration Syntax
C# Visual Basic Visual C++
public class CommandControlBuilder
Public Class CommandControlBuilder
public ref class CommandControlBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CommandControlBuilder()()() |
 | CommandItemClick(Object, EventArgs) | Handles the click event of a tool strip item, if the Tag is an ICommand instance the action is executed.
 | CreateLinkLabel<(Of <(TCommand>)>)()()() | Creates a link label given the TCommand definition.
 | CreateToolStripButton<(Of <(TCommand>)>)()()() | Creates a tool strip button given the TCommand definition.
 | CreateToolStripMenuItem<(Of <(TCommand>)>)()()() | Creates a tool strip menu item given the TCommand definition.
 | CreateToolStripMenuItemSeperator()()() | Creates a tool strip menu item seperator.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | MonitorMenuItemsOpeningForEnabling(ToolStrip) | Assigns an event handler (TopLevelMenuDropDownOpening(Object, EventArgs)) to the opening event for menu strip items which in turn hadles enableing and disabling.
 | TopLevelMenuDropDownOpening(Object, EventArgs) | Used when a menu is opening, handles enabling/dusabling of items for display.
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CommandControlBuilder


CommandControlBuilder Constructor

CommandControlBuilder Constructor
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CommandControlBuilder()()()
Initializes a new instance of the CommandControlBuilder class.
Declaration Syntax
C# Visual Basic Visual C++
public CommandControlBuilder()
Public Sub New
public:
CommandControlBuilder()


CommandItemClick Method (sender, e)

CommandItemClick Method (sender, e)
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CommandItemClick(Object, EventArgs)
Handles the click event of a tool strip item, if the Tag is an ICommand instance the action is executed.
Declaration Syntax
C# Visual Basic Visual C++
public static void CommandItemClick(
    Object sender,
    EventArgs e
)
Public Shared Sub CommandItemClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
static void CommandItemClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.


CreateLinkLabel Method

CreateLinkLabel<(Of <(TCommand>)>) Method
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CreateLinkLabel<(Of <(TCommand>)>)()()()
Creates a link label given the TCommand definition.
Declaration Syntax
C# Visual Basic Visual C++
public static LinkLabel CreateLinkLabel<TCommand>() where TCommand : new(), ICommand
Public Shared Function CreateLinkLabel(Of TCommand As {New, ICommand}) As LinkLabel
public:
generic<typename TCommand>
where TCommand : gcnew(), ICommand
static LinkLabel^ CreateLinkLabel()
Generic Template Parameters
TCommand
The type of the command.
Return Value
A link label wired to the commands Execute()()() method.


CreateToolStripButton Method

CreateToolStripButton<(Of <(TCommand>)>) Method
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CreateToolStripButton<(Of <(TCommand>)>)()()()
Creates a tool strip button given the TCommand definition.
Declaration Syntax
C# Visual Basic Visual C++
public static ToolStripButton CreateToolStripButton<TCommand>() where TCommand : new(), ICommand
Public Shared Function CreateToolStripButton(Of TCommand As {New, ICommand}) As ToolStripButton
public:
generic<typename TCommand>
where TCommand : gcnew(), ICommand
static ToolStripButton^ CreateToolStripButton()
Generic Template Parameters
TCommand
The type of the command.
Return Value
A tool strip button


CreateToolStripMenuItem Method

CreateToolStripMenuItem<(Of <(TCommand>)>) Method
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CreateToolStripMenuItem<(Of <(TCommand>)>)()()()
Creates a tool strip menu item given the TCommand definition.
Declaration Syntax
C# Visual Basic Visual C++
public static ToolStripMenuItem CreateToolStripMenuItem<TCommand>() where TCommand : new(), ICommand
Public Shared Function CreateToolStripMenuItem(Of TCommand As {New, ICommand}) As ToolStripMenuItem
public:
generic<typename TCommand>
where TCommand : gcnew(), ICommand
static ToolStripMenuItem^ CreateToolStripMenuItem()
Generic Template Parameters
TCommand
The type of the command.
Return Value
A tool strip menu item wired to the commands Execute()()() method.


CreateToolStripMenuItemSeperator Method

CreateToolStripMenuItemSeperator Method
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► CreateToolStripMenuItemSeperator()()()
Creates a tool strip menu item seperator.
Declaration Syntax
C# Visual Basic Visual C++
public static ToolStripSeparator CreateToolStripMenuItemSeperator()
Public Shared Function CreateToolStripMenuItemSeperator As ToolStripSeparator
public:
static ToolStripSeparator^ CreateToolStripMenuItemSeperator()
Return Value
A tool strip seperator.


MonitorMenuItemsOpeningForEnabling Method (menuStrip)

MonitorMenuItemsOpeningForEnabling Method (menuStrip)
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► MonitorMenuItemsOpeningForEnabling(ToolStrip)
Assigns an event handler (TopLevelMenuDropDownOpening(Object, EventArgs)) to the opening event for menu strip items which in turn hadles enableing and disabling.
Declaration Syntax
C# Visual Basic Visual C++
public static void MonitorMenuItemsOpeningForEnabling(
    ToolStrip menuStrip
)
Public Shared Sub MonitorMenuItemsOpeningForEnabling ( _
    menuStrip As ToolStrip _
)
public:
static void MonitorMenuItemsOpeningForEnabling(
    ToolStrip^ menuStrip
)
Parameters
menuStrip (ToolStrip)
The menu strip to monitor.


TopLevelMenuDropDownOpening Method (sender, e)

TopLevelMenuDropDownOpening Method (sender, e)
Namespaces ► MiniSqlQuery.Core ► CommandControlBuilder ► TopLevelMenuDropDownOpening(Object, EventArgs)
Used when a menu is opening, handles enabling/dusabling of items for display.
Declaration Syntax
C# Visual Basic Visual C++
public static void TopLevelMenuDropDownOpening(
    Object sender,
    EventArgs e
)
Public Shared Sub TopLevelMenuDropDownOpening ( _
    sender As Object, _
    e As EventArgs _
)
public:
static void TopLevelMenuDropDownOpening(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.


CommandManager Class

CommandManager Class
Namespaces ► MiniSqlQuery.Core ► CommandManager
Stores instances of commands by type.
Declaration Syntax
C# Visual Basic Visual C++
public class CommandManager
Public Class CommandManager
public ref class CommandManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CommandManager()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetCommandInstance(String) | Gets the command instance by commandTypeName.
 | GetCommandInstance<(Of <(TCommand>)>)()()() | Gets or creates an instance of a command by type.
 | GetCommandInstanceByPartialName(String) | Gets command instance by it's partial name, e.g. "OpenFile".
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CommandManager


CommandManager Constructor

CommandManager Constructor
Namespaces ► MiniSqlQuery.Core ► CommandManager ► CommandManager()()()
Initializes a new instance of the CommandManager class.
Declaration Syntax
C# Visual Basic Visual C++
public CommandManager()
Public Sub New
public:
CommandManager()


GetCommandInstance Method

GetCommandInstance Method
Namespaces ► MiniSqlQuery.Core ► CommandManager ► GetCommandInstance()()()
Members
Icon | Member | Description
 | GetCommandInstance(String) | Gets the command instance by commandTypeName.
 | GetCommandInstance<(Of <(TCommand>)>)()()() | Gets or creates an instance of a command by type.


GetCommandInstance Method

GetCommandInstance<(Of <(TCommand>)>) Method
Namespaces ► MiniSqlQuery.Core ► CommandManager ► GetCommandInstance<(Of <(TCommand>)>)()()()
Gets or creates an instance of a command by type.
Declaration Syntax
C# Visual Basic Visual C++
public static ICommand GetCommandInstance<TCommand>() where TCommand : new(), ICommand
Public Shared Function GetCommandInstance(Of TCommand As {New, ICommand}) As ICommand
public:
generic<typename TCommand>
where TCommand : gcnew(), ICommand
static ICommand^ GetCommandInstance()
Generic Template Parameters
TCommand
The type of command to get or create.
Return Value
An instance of TCommand.


GetCommandInstance Method (commandTypeName)

GetCommandInstance Method (commandTypeName)
Namespaces ► MiniSqlQuery.Core ► CommandManager ► GetCommandInstance(String)
Gets the command instance by commandTypeName.
Declaration Syntax
C# Visual Basic Visual C++
public static ICommand GetCommandInstance(
    string commandTypeName
)
Public Shared Function GetCommandInstance ( _
    commandTypeName As String _
) As ICommand
public:
static ICommand^ GetCommandInstance(
    String^ commandTypeName
)
Parameters
commandTypeName (String)
Name of the command, e.g. "OpenFileCommand".
Return Value
The first command by that name or null if not found.


GetCommandInstanceByPartialName Method (commandName)

GetCommandInstanceByPartialName Method (commandName)
Namespaces ► MiniSqlQuery.Core ► CommandManager ► GetCommandInstanceByPartialName(String)
Gets command instance by it's partial name, e.g. "OpenFile".
Declaration Syntax
C# Visual Basic Visual C++
public static ICommand GetCommandInstanceByPartialName(
    string commandName
)
Public Shared Function GetCommandInstanceByPartialName ( _
    commandName As String _
) As ICommand
public:
static ICommand^ GetCommandInstanceByPartialName(
    String^ commandName
)
Parameters
commandName (String)
Name partial of the command.
Return Value
The first command by that name or null if not found.


ConnectionDefinition Class

ConnectionDefinition Class
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition
Provides a defition of database connections by provider and name.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute]
public class ConnectionDefinition
<ObsoleteAttribute> _
Public Class ConnectionDefinition
[ObsoleteAttribute]
public ref class ConnectionDefinition
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionDefinition()()() | Initializes a new instance of the ConnectionDefinition class.
 | CommentPrefix | The prefix character for comments in the definition text.
 | ConnectionString | Gets or sets the connection string.
 | Default | A default connection, an MSSQL db on localhost connecting to "master".
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Name | Gets or sets the name.
 | Parse(String) | Parses the specified definition string.
 | Parse(array<String>[]()[]) | Parses the specified definitions.
 | ProviderName | Gets or sets the name of the provider.
 | SplitChar | The character used to "split" the definition text into its components.
 | ToParsableFormat()()() | Converts the data to a parsable format.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
ConnectionDefinition


ConnectionDefinition Constructor

ConnectionDefinition Constructor
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► ConnectionDefinition()()()
Initializes a new instance of the ConnectionDefinition class.
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionDefinition()
Public Sub New
public:
ConnectionDefinition()


CommentPrefix Field

CommentPrefix Field
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► CommentPrefix
The prefix character for comments in the definition text.
Declaration Syntax
C# Visual Basic Visual C++
public const string CommentPrefix
Public Const CommentPrefix As String
public:
literal String^ CommentPrefix


ConnectionString Property

ConnectionString Property
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► ConnectionString
Gets or sets the connection string.
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionString { get; set; }
Public Property ConnectionString As String
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
Value
The connection string.


Default Field

Default Field
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► Default
A default connection, an MSSQL db on localhost connecting to "master".
Declaration Syntax
C# Visual Basic Visual C++
public static readonly ConnectionDefinition Default
Public Shared ReadOnly Default As ConnectionDefinition
public:
static initonly ConnectionDefinition^ Default


Name Property

Name Property
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► Name
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.


Parse Method

Parse Method
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► Parse()()()
Members
Icon | Member | Description
 | Parse(String) | Parses the specified definition string.
 | Parse(array<String>[]()[]) | Parses the specified definitions.


Parse Method (definition)

Parse Method (definition)
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► Parse(String)
Parses the specified definition string.
Declaration Syntax
C# Visual Basic Visual C++
public static ConnectionDefinition Parse(
    string definition
)
Public Shared Function Parse ( _
    definition As String _
) As ConnectionDefinition
public:
static ConnectionDefinition^ Parse(
    String^ definition
)
Parameters
definition (String)
The definition string, e.g. "Default - MSSQL Master@localhost ^ System.Data.SqlClient ^ Server=.; Database=master; Integrated Security=SSPI".
Return Value
A new ConnectionDefinition object or null.


Parse Method (definitions)

Parse Method (definitions)
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► Parse(array<String>[]()[])
Parses the specified definitions.
Declaration Syntax
C# Visual Basic Visual C++
public static ConnectionDefinition[] Parse(
    string[] definitions
)
Public Shared Function Parse ( _
    definitions As String() _
) As ConnectionDefinition()
public:
static array<ConnectionDefinition^>^ Parse(
    array<String^>^ definitions
)
Parameters
definitions (array< String >[]()[])
The definitions.
Return Value
An array of ConnectionDefinition objects.


ProviderName Property

ProviderName Property
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► ProviderName
Gets or sets the name of the provider.
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderName { get; set; }
Public Property ProviderName As String
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the provider.


SplitChar Field

SplitChar Field
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► SplitChar
The character used to "split" the definition text into its components.
Declaration Syntax
C# Visual Basic Visual C++
public const char SplitChar
Public Const SplitChar As Char
public:
literal wchar_t SplitChar


ToParsableFormat Method

ToParsableFormat Method
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► ToParsableFormat()()()
Converts the data to a parsable format.
Declaration Syntax
C# Visual Basic Visual C++
public string ToParsableFormat()
Public Function ToParsableFormat As String
public:
String^ ToParsableFormat()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.ConnectionDefinition.ToParsableFormat]


ToString Method

ToString Method
Namespaces ► MiniSqlQuery.Core ► ConnectionDefinition ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


DatabaseMetaDataService Class

DatabaseMetaDataService Class
Namespaces ► MiniSqlQuery.Core ► DatabaseMetaDataService
Creates a simplified view of the database schema for a given provider and connection string.
Declaration Syntax
C# Visual Basic Visual C++
public class DatabaseMetaDataService
Public Class DatabaseMetaDataService
public ref class DatabaseMetaDataService
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseMetaDataService(DbProviderFactory, String) | Initializes a new instance of the DatabaseMetaDataService class.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetDataTypes()()() | Get the data types collection.
 | GetDescription()()() | Gets the description of the data source
 | GetHashCode()()() | (Inherited from Object.)
 | GetSchema()()() | Gets a simplified schema.
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseMetaDataService


DatabaseMetaDataService Constructor (factory, connection)

DatabaseMetaDataService Constructor (factory, connection)
Namespaces ► MiniSqlQuery.Core ► DatabaseMetaDataService ► DatabaseMetaDataService(DbProviderFactory, String)
Initializes a new instance of the DatabaseMetaDataService class.
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseMetaDataService(
    DbProviderFactory factory,
    string connection
)
Public Sub New ( _
    factory As DbProviderFactory, _
    connection As String _
)
public:
DatabaseMetaDataService(
    DbProviderFactory^ factory,
    String^ connection
)
Parameters
factory (DbProviderFactory)
The provider factory to use.
connection (String)
The connection string


GetDataTypes Method

GetDataTypes Method
Namespaces ► MiniSqlQuery.Core ► DatabaseMetaDataService ► GetDataTypes()()()
Get the data types collection.
Declaration Syntax
C# Visual Basic Visual C++
public DataTable GetDataTypes()
Public Function GetDataTypes As DataTable
public:
DataTable^ GetDataTypes()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.DatabaseMetaDataService.GetDataTypes]


GetDescription Method

GetDescription Method
Namespaces ► MiniSqlQuery.Core ► DatabaseMetaDataService ► GetDescription()()()
Gets the description of the data source
Declaration Syntax
C# Visual Basic Visual C++
public string GetDescription()
Public Function GetDescription As String
public:
String^ GetDescription()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.DatabaseMetaDataService.GetDescription]


GetSchema Method

GetSchema Method
Namespaces ► MiniSqlQuery.Core ► DatabaseMetaDataService ► GetSchema()()()
Gets a simplified schema.
Declaration Syntax
C# Visual Basic Visual C++
public DataTable GetSchema()
Public Function GetSchema As DataTable
public:
DataTable^ GetSchema()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.DatabaseMetaDataService.GetSchema]

Remarks
  • Schema string
  • Table string
  • Column string
  • DataType string
  • Length int
  • IsNullable bool


DbConnectionDefinition Class

DbConnectionDefinition Class
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition
Provides a defition of database connection by provider and name.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DbConnectionDefinition
<SerializableAttribute> _
Public Class DbConnectionDefinition
[SerializableAttribute]
public ref class DbConnectionDefinition
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DbConnectionDefinition()()() | Initializes a new instance of the DbConnectionDefinition class.
 | Comment | Gets or sets a comment in relation to this connection, e.g. "development..."
 | ConnectionString | Gets or sets the connection string.
 | Default | A default connection, an MSSQL db on localhost connecting to "master".
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Name | Gets or sets the name.
 | ProviderName | Gets or sets the name of the provider.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | ToXml()()() | Serialize the object to XML.
Inheritance Hierarchy
Object
DbConnectionDefinition


DbConnectionDefinition Constructor

DbConnectionDefinition Constructor
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► DbConnectionDefinition()()()
Initializes a new instance of the DbConnectionDefinition class.
Declaration Syntax
C# Visual Basic Visual C++
public DbConnectionDefinition()
Public Sub New
public:
DbConnectionDefinition()


Comment Property

Comment Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► Comment
Gets or sets a comment in relation to this connection, e.g. "development..."
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; set; }
Public Property Comment As String
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
Value
A comment.


ConnectionString Property

ConnectionString Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► ConnectionString
Gets or sets the connection string.
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionString { get; set; }
Public Property ConnectionString As String
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
Value
The connection string.


Default Field

Default Field
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► Default
A default connection, an MSSQL db on localhost connecting to "master".
Declaration Syntax
C# Visual Basic Visual C++
public static readonly DbConnectionDefinition Default
Public Shared ReadOnly Default As DbConnectionDefinition
public:
static initonly DbConnectionDefinition^ Default


Name Property

Name Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► Name
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.


ProviderName Property

ProviderName Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► ProviderName
Gets or sets the name of the provider.
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderName { get; set; }
Public Property ProviderName As String
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the provider.


ToString Method

ToString Method
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


ToXml Method

ToXml Method
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinition ► ToXml()()()
Serialize the object to XML.
Declaration Syntax
C# Visual Basic Visual C++
public string ToXml()
Public Function ToXml As String
public:
String^ ToXml()
Return Value
An XML string.


DbConnectionDefinitionList Class

DbConnectionDefinitionList Class
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList

[Missing <summary> documentation for T:MiniSqlQuery.Core.DbConnectionDefinitionList]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DbConnectionDefinitionList
<SerializableAttribute> _
Public Class DbConnectionDefinitionList
[SerializableAttribute]
public ref class DbConnectionDefinitionList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DbConnectionDefinitionList()()() |
 | DefaultName |
 | Definitions |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | FromXml(String) |
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
 | ToXml()()() | Serialize the object to XML.
 | Upgrade(array<ConnectionDefinition>[]()[], String) |
Inheritance Hierarchy
Object
DbConnectionDefinitionList


DbConnectionDefinitionList Constructor

DbConnectionDefinitionList Constructor
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► DbConnectionDefinitionList()()()
Initializes a new instance of the DbConnectionDefinitionList class.
Declaration Syntax
C# Visual Basic Visual C++
public DbConnectionDefinitionList()
Public Sub New
public:
DbConnectionDefinitionList()


DefaultName Property

DefaultName Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► DefaultName

[Missing <summary> documentation for P:MiniSqlQuery.Core.DbConnectionDefinitionList.DefaultName]

Declaration Syntax
C# Visual Basic Visual C++
public string DefaultName { get; set; }
Public Property DefaultName As String
public:
property String^ DefaultName {
    String^ get ();
    void set (String^ value);
}


Definitions Property

Definitions Property
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► Definitions

[Missing <summary> documentation for P:MiniSqlQuery.Core.DbConnectionDefinitionList.Definitions]

Declaration Syntax
C# Visual Basic Visual C++
public DbConnectionDefinition[] Definitions { get; set; }
Public Property Definitions As DbConnectionDefinition()
public:
property array<DbConnectionDefinition^>^ Definitions {
    array<DbConnectionDefinition^>^ get ();
    void set (array<DbConnectionDefinition^>^ value);
}


FromXml Method (xml)

FromXml Method (xml)
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► FromXml(String)

[Missing <summary> documentation for M:MiniSqlQuery.Core.DbConnectionDefinitionList.FromXml(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static DbConnectionDefinitionList FromXml(
    string xml
)
Public Shared Function FromXml ( _
    xml As String _
) As DbConnectionDefinitionList
public:
static DbConnectionDefinitionList^ FromXml(
    String^ xml
)
Parameters
xml (String)

[Missing <param> documentation for "xml"]

Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.DbConnectionDefinitionList.FromXml(System.String)]


ToXml Method

ToXml Method
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► ToXml()()()
Serialize the object to XML.
Declaration Syntax
C# Visual Basic Visual C++
public string ToXml()
Public Function ToXml As String
public:
String^ ToXml()
Return Value
An XML string.


Upgrade Method (oldDefinitions, defaultName)

Upgrade Method (oldDefinitions, defaultName)
Namespaces ► MiniSqlQuery.Core ► DbConnectionDefinitionList ► Upgrade(array<ConnectionDefinition>[]()[], String)

[Missing <summary> documentation for M:MiniSqlQuery.Core.DbConnectionDefinitionList.Upgrade(MiniSqlQuery.Core.ConnectionDefinition[],System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static DbConnectionDefinitionList Upgrade(
    ConnectionDefinition[] oldDefinitions,
    string defaultName
)
Public Shared Function Upgrade ( _
    oldDefinitions As ConnectionDefinition(), _
    defaultName As String _
) As DbConnectionDefinitionList
public:
static DbConnectionDefinitionList^ Upgrade(
    array<ConnectionDefinition^>^ oldDefinitions,
    String^ defaultName
)
Parameters
oldDefinitions (array< ConnectionDefinition >[]()[])

[Missing <param> documentation for "oldDefinitions"]

defaultName (String)

[Missing <param> documentation for "defaultName"]

Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.DbConnectionDefinitionList.Upgrade(MiniSqlQuery.Core.ConnectionDefinition[],System.String)]


FindTextRequest Class

FindTextRequest Class
Namespaces ► MiniSqlQuery.Core ► FindTextRequest
A class that encapsulates a "find text" request, storing the position
Declaration Syntax
C# Visual Basic Visual C++
public class FindTextRequest
Public Class FindTextRequest
public ref class FindTextRequest
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindTextRequest(IFindReplaceProvider) | Creates a new request using the specified textProvider for searching.
 | FindTextRequest(IFindReplaceProvider, String) | Creates a new request using the specified textProvider for searching.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Position | The position of the currently "found" text (or the starting position of the search).
 | SearchUp | If true, signals the TextProvider to search "up", otherwise "down".
 | SearchValue | The search text.
 | StringComparison | The string comparison settings, e.g. case insensitive.
 | TextProvider | The search provider. A search request is conducted by the provider, different providers can yield different results, for example plain text or a regular expression searcher.
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
FindTextRequest


FindTextRequest Constructor

FindTextRequest Constructor
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► FindTextRequest()()()
Members
Icon | Member | Description
 | FindTextRequest(IFindReplaceProvider) | Creates a new request using the specified textProvider for searching.
 | FindTextRequest(IFindReplaceProvider, String) | Creates a new request using the specified textProvider for searching.


FindTextRequest Constructor (textProvider)

FindTextRequest Constructor (textProvider)
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► FindTextRequest(IFindReplaceProvider)
Creates a new request using the specified textProvider for searching.
Declaration Syntax
C# Visual Basic Visual C++
public FindTextRequest(
    IFindReplaceProvider textProvider
)
Public Sub New ( _
    textProvider As IFindReplaceProvider _
)
public:
FindTextRequest(
    IFindReplaceProvider^ textProvider
)
Parameters
textProvider (IFindReplaceProvider)
The search provider for this request,


FindTextRequest Constructor (textProvider, searchValue)

FindTextRequest Constructor (textProvider, searchValue)
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► FindTextRequest(IFindReplaceProvider, String)
Creates a new request using the specified textProvider for searching.
Declaration Syntax
C# Visual Basic Visual C++
public FindTextRequest(
    IFindReplaceProvider textProvider,
    string searchValue
)
Public Sub New ( _
    textProvider As IFindReplaceProvider, _
    searchValue As String _
)
public:
FindTextRequest(
    IFindReplaceProvider^ textProvider,
    String^ searchValue
)
Parameters
textProvider (IFindReplaceProvider)
The search provider for this request,
searchValue (String)
The text to be searched on.


Position Property

Position Property
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► Position
The position of the currently "found" text (or the starting position of the search).
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; set; }
Public Property Position As Integer
public:
property int Position {
    int get ();
    void set (int value);
}


SearchUp Property

SearchUp Property
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► SearchUp
If true, signals the TextProvider to search "up", otherwise "down".
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchUp { get; set; }
Public Property SearchUp As Boolean
public:
property bool SearchUp {
    bool get ();
    void set (bool value);
}
Value
True to search up, false for down (the default).


SearchValue Property

SearchValue Property
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► SearchValue
The search text.
Declaration Syntax
C# Visual Basic Visual C++
public string SearchValue { get; set; }
Public Property SearchValue As String
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}


StringComparison Property

StringComparison Property
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► StringComparison
The string comparison settings, e.g. case insensitive.
Declaration Syntax
C# Visual Basic Visual C++
public StringComparison StringComparison { get; set; }
Public Property StringComparison As StringComparison
public:
property StringComparison StringComparison {
    StringComparison get ();
    void set (StringComparison value);
}


TextProvider Property

TextProvider Property
Namespaces ► MiniSqlQuery.Core ► FindTextRequest ► TextProvider
The search provider. A search request is conducted by the provider, different providers can yield different results, for example plain text or a regular expression searcher.
Declaration Syntax
C# Visual Basic Visual C++
public IFindReplaceProvider TextProvider { get; set; }
Public Property TextProvider As IFindReplaceProvider
public:
property IFindReplaceProvider^ TextProvider {
    IFindReplaceProvider^ get ();
    void set (IFindReplaceProvider^ value);
}


IApplicationServices Interface

IApplicationServices Interface
Namespaces ► MiniSqlQuery.Core ► IApplicationServices
The core services of the application.
Declaration Syntax
C# Visual Basic Visual C++
public interface IApplicationServices
Public Interface IApplicationServices
public interface class IApplicationServices
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Container | The Dependency Injection container. This container holds all major application components and plugins. See the "Configuration.xml" file in the main application for settings.
 | HostWindow | The application host window.
 | InitializePlugIns()()() | Initializes the plugins that have been loaded during application startup.
 | LoadPlugIn(IPlugIn) | Loads the plugIn (calling its LoadPlugIn(IApplicationServices) method) and adds it to the Plugins dictionary for access by other services.
 | Plugins | A dictionary of the current plugins for this application.
 | Settings | The application settings instance.


Container Property

Container Property
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► Container
The Dependency Injection container. This container holds all major application components and plugins. See the "Configuration.xml" file in the main application for settings.
Declaration Syntax
C# Visual Basic Visual C++
IWindsorContainer Container { get; }
ReadOnly Property Container As IWindsorContainer
property IWindsorContainer^ Container {
    IWindsorContainer^ get ();
}


HostWindow Property

HostWindow Property
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► HostWindow
The application host window.
Declaration Syntax
C# Visual Basic Visual C++
IHostWindow HostWindow { get; }
ReadOnly Property HostWindow As IHostWindow
property IHostWindow^ HostWindow {
    IHostWindow^ get ();
}
Value
The application host window - a Form.


InitializePlugIns Method

InitializePlugIns Method
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► InitializePlugIns()()()
Initializes the plugins that have been loaded during application startup.
Declaration Syntax
C# Visual Basic Visual C++
void InitializePlugIns()
Sub InitializePlugIns
void InitializePlugIns()


LoadPlugIn Method (plugIn)

LoadPlugIn Method (plugIn)
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► LoadPlugIn(IPlugIn)
Loads the plugIn (calling its LoadPlugIn(IApplicationServices) method) and adds it to the Plugins dictionary for access by other services.
Declaration Syntax
C# Visual Basic Visual C++
void LoadPlugIn(
    IPlugIn plugIn
)
Sub LoadPlugIn ( _
    plugIn As IPlugIn _
)
void LoadPlugIn(
    IPlugIn^ plugIn
)
Parameters
plugIn (IPlugIn)
The plugin to load.
Exceptions
Exception | Condition
ArgumentNullException | If plugIn is null.


Plugins Property

Plugins Property
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► Plugins
A dictionary of the current plugins for this application.
Declaration Syntax
C# Visual Basic Visual C++
Dictionary<Type, IPlugIn> Plugins { get; }
ReadOnly Property Plugins As Dictionary(Of Type, IPlugIn)
property Dictionary<Type^, IPlugIn^>^ Plugins {
    Dictionary<Type^, IPlugIn^>^ get ();
}
Value
A reference to the plugin dictionary.


Settings Property

Settings Property
Namespaces ► MiniSqlQuery.Core ► IApplicationServices ► Settings
The application settings instance.
Declaration Syntax
C# Visual Basic Visual C++
IApplicationSettings Settings { get; }
ReadOnly Property Settings As IApplicationSettings
property IApplicationSettings^ Settings {
    IApplicationSettings^ get ();
}
Value
A reference to the settings handler.


IApplicationSettings Interface

IApplicationSettings Interface
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings
An interface for the application settings.
Declaration Syntax
C# Visual Basic Visual C++
public interface IApplicationSettings
Public Interface IApplicationSettings
public interface class IApplicationSettings
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Connection | Gets an instance of DbConnection depending on the value of ConnectionDefinition.
 | ConnectionDefinition | A reference to the current connection definiton class.
 | ConnectionDefinitionsChanged | Fired when the list of connection definitions is modified.
 | DatabaseConnectionReset | Fired when the database connection (provider and/or connection string) are modified.
 | DefaultFileFilter | The default filter string for dialog boxes.
 | GetConnectionDefinitions()()() | Gets the current connection definitions for this user.
 | GetOpenConnection()()() | Helper method to get an open connection.
 | ProviderFactory | Gets an instance of DbProviderFactory depending on the value of ConnectionDefinition.
 | ResetConnection()()() | Resets the connection details firing the DatabaseConnectionReset event.
 | SetConnectionDefinitions(DbConnectionDefinitionList) | Resets the list of connection definitions that are stored in the user profile.


Connection Property

Connection Property
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► Connection
Gets an instance of DbConnection depending on the value of ConnectionDefinition.
Declaration Syntax
C# Visual Basic Visual C++
DbConnection Connection { get; }
ReadOnly Property Connection As DbConnection
property DbConnection^ Connection {
    DbConnection^ get ();
}


ConnectionDefinition Property

ConnectionDefinition Property
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► ConnectionDefinition
A reference to the current connection definiton class.
Declaration Syntax
C# Visual Basic Visual C++
DbConnectionDefinition ConnectionDefinition { get; set; }
Property ConnectionDefinition As DbConnectionDefinition
property DbConnectionDefinition^ ConnectionDefinition {
    DbConnectionDefinition^ get ();
    void set (DbConnectionDefinition^ value);
}


ConnectionDefinitionsChanged Event

ConnectionDefinitionsChanged Event
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► ConnectionDefinitionsChanged
Fired when the list of connection definitions is modified.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler ConnectionDefinitionsChanged
Event ConnectionDefinitionsChanged As EventHandler
 event EventHandler^ ConnectionDefinitionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
See Also
SetConnectionDefinitions(DbConnectionDefinitionList)
GetConnectionDefinitions()()()


DatabaseConnectionReset Event

DatabaseConnectionReset Event
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► DatabaseConnectionReset
Fired when the database connection (provider and/or connection string) are modified.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler DatabaseConnectionReset
Event DatabaseConnectionReset As EventHandler
 event EventHandler^ DatabaseConnectionReset {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
See Also
ResetConnection()()()


DefaultFileFilter Property

DefaultFileFilter Property
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► DefaultFileFilter
The default filter string for dialog boxes.
Declaration Syntax
C# Visual Basic Visual C++
string DefaultFileFilter { get; }
ReadOnly Property DefaultFileFilter As String
property String^ DefaultFileFilter {
    String^ get ();
}


GetConnectionDefinitions Method

GetConnectionDefinitions Method
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► GetConnectionDefinitions()()()
Gets the current connection definitions for this user.
Declaration Syntax
C# Visual Basic Visual C++
DbConnectionDefinitionList GetConnectionDefinitions()
Function GetConnectionDefinitions As DbConnectionDefinitionList
DbConnectionDefinitionList^ GetConnectionDefinitions()
Return Value
Connection definitions.


GetOpenConnection Method

GetOpenConnection Method
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► GetOpenConnection()()()
Helper method to get an open connection.
Declaration Syntax
C# Visual Basic Visual C++
DbConnection GetOpenConnection()
Function GetOpenConnection As DbConnection
DbConnection^ GetOpenConnection()
Return Value
A DbConnection object.


ProviderFactory Property

ProviderFactory Property
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► ProviderFactory
Gets an instance of DbProviderFactory depending on the value of ConnectionDefinition.
Declaration Syntax
C# Visual Basic Visual C++
DbProviderFactory ProviderFactory { get; }
ReadOnly Property ProviderFactory As DbProviderFactory
property DbProviderFactory^ ProviderFactory {
    DbProviderFactory^ get ();
}


ResetConnection Method

ResetConnection Method
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► ResetConnection()()()
Resets the connection details firing the DatabaseConnectionReset event.
Declaration Syntax
C# Visual Basic Visual C++
void ResetConnection()
Sub ResetConnection
void ResetConnection()
See Also
DatabaseConnectionReset


SetConnectionDefinitions Method (definitionList)

SetConnectionDefinitions Method (definitionList)
Namespaces ► MiniSqlQuery.Core ► IApplicationSettings ► SetConnectionDefinitions(DbConnectionDefinitionList)
Resets the list of connection definitions that are stored in the user profile.
Declaration Syntax
C# Visual Basic Visual C++
void SetConnectionDefinitions(
    DbConnectionDefinitionList definitionList
)
Sub SetConnectionDefinitions ( _
    definitionList As DbConnectionDefinitionList _
)
void SetConnectionDefinitions(
    DbConnectionDefinitionList^ definitionList
)
Parameters
definitionList (DbConnectionDefinitionList)

[Missing <param> documentation for "definitionList"]


ICommand Interface

ICommand Interface
Namespaces ► MiniSqlQuery.Core ► ICommand
Represents a "command", typically a user action such as saving a file or executing a query.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommand
Public Interface ICommand
public interface class ICommand
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enabled | Gets a value indicating whether this ICommand is enabled.
 | Execute()()() | Executes the command based on the current settings.
 | Name | The name of the command, used in menus and buttons.
 | Services | A reference to the application services to allow access to the other components.
 | ShortcutKeys | Gets the menu shortcut keys for this command (e.g. Keys.F5).
 | SmallImage | Gets the "small image" associated with this control (for use on buttons or menu items). Use null (or Nothing in Visual Basic) if there is no image.


Enabled Property

Enabled Property
Namespaces ► MiniSqlQuery.Core ► ICommand ► Enabled
Gets a value indicating whether this ICommand is enabled.
Declaration Syntax
C# Visual Basic Visual C++
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
property bool Enabled {
    bool get ();
}
Value
true if enabled; otherwise, false.


Execute Method

Execute Method
Namespaces ► MiniSqlQuery.Core ► ICommand ► Execute()()()
Executes the command based on the current settings.
Declaration Syntax
C# Visual Basic Visual C++
void Execute()
Sub Execute
void Execute()
Remarks
If a commands Enabled value is false, a call to Execute()()() should have no effect (and not throw an exception).


Name Property

Name Property
Namespaces ► MiniSqlQuery.Core ► ICommand ► Name
The name of the command, used in menus and buttons.
Declaration Syntax
C# Visual Basic Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}
Value
The name of the command.


Services Property

Services Property
Namespaces ► MiniSqlQuery.Core ► ICommand ► Services
A reference to the application services to allow access to the other components.
Declaration Syntax
C# Visual Basic Visual C++
IApplicationServices Services { get; set; }
Property Services As IApplicationServices
property IApplicationServices^ Services {
    IApplicationServices^ get ();
    void set (IApplicationServices^ value);
}
Value
A reference to the IApplicationServices instance.


ShortcutKeys Property

ShortcutKeys Property
Namespaces ► MiniSqlQuery.Core ► ICommand ► ShortcutKeys
Gets the menu shortcut keys for this command (e.g. Keys.F5).
Declaration Syntax
C# Visual Basic Visual C++
Keys ShortcutKeys { get; }
ReadOnly Property ShortcutKeys As Keys
property Keys ShortcutKeys {
    Keys get ();
}
Value
The shortcut keys for this command.


SmallImage Property

SmallImage Property
Namespaces ► MiniSqlQuery.Core ► ICommand ► SmallImage
Gets the "small image" associated with this control (for use on buttons or menu items). Use null (or Nothing in Visual Basic) if there is no image.
Declaration Syntax
C# Visual Basic Visual C++
Image SmallImage { get; }
ReadOnly Property SmallImage As Image
property Image^ SmallImage {
    Image^ get ();
}
Value
The small image representing this command (or null for none).


IDatabaseInspector Interface

IDatabaseInspector Interface
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector
An interface to the query windows database inspector.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDatabaseInspector
Public Interface IDatabaseInspector
public interface class IDatabaseInspector
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Close()()() | Close the window.
 | DbSchema | Gets the current database schema info (if any).
 | LoadDatabaseDetails()()() | Reloads the meta-data and re-builds the tree.
 | RightClickedTableName | The name of the curent table in the tree view that is being clicked.
 | TableMenu | Provides access to the Table context menu strip.


Close Method

Close Method
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector ► Close()()()
Close the window.
Declaration Syntax
C# Visual Basic Visual C++
void Close()
Sub Close
void Close()


DbSchema Property

DbSchema Property
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector ► DbSchema
Gets the current database schema info (if any).
Declaration Syntax
C# Visual Basic Visual C++
DataTable DbSchema { get; }
ReadOnly Property DbSchema As DataTable
property DataTable^ DbSchema {
    DataTable^ get ();
}


LoadDatabaseDetails Method

LoadDatabaseDetails Method
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector ► LoadDatabaseDetails()()()
Reloads the meta-data and re-builds the tree.
Declaration Syntax
C# Visual Basic Visual C++
void LoadDatabaseDetails()
Sub LoadDatabaseDetails
void LoadDatabaseDetails()


RightClickedTableName Property

RightClickedTableName Property
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector ► RightClickedTableName
The name of the curent table in the tree view that is being clicked.
Declaration Syntax
C# Visual Basic Visual C++
string RightClickedTableName { get; }
ReadOnly Property RightClickedTableName As String
property String^ RightClickedTableName {
    String^ get ();
}
Value
The table name or null if none selected.


TableMenu Property

TableMenu Property
Namespaces ► MiniSqlQuery.Core ► IDatabaseInspector ► TableMenu
Provides access to the Table context menu strip.
Declaration Syntax
C# Visual Basic Visual C++
ContextMenuStrip TableMenu { get; }
ReadOnly Property TableMenu As ContextMenuStrip
property ContextMenuStrip^ TableMenu {
    ContextMenuStrip^ get ();
}


IFindReplaceProvider Interface

IFindReplaceProvider Interface
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider
A control that allows its text to be "found" and optionally "replaced". The query editor is an obvious provider but other windows can also provide find/replace functionality by implementing this interface (tools, output windows etc).
Declaration Syntax
C# Visual Basic Visual C++
public interface IFindReplaceProvider : ISupportCursorOffset
Public Interface IFindReplaceProvider _
    Implements ISupportCursorOffset
public interface class IFindReplaceProvider : ISupportCursorOffset
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanReplaceText | True if the text can be replaced, otherwise false.
 | CursorOffset | Gets the cursor offset. (Inherited from ISupportCursorOffset.)
 | FindString(String, Int32, StringComparison) | Attemps to find value in the controls text.
 | ReplaceString(String, Int32, Int32) | Replaces the text from startIndex for length characters with value.
 | SetTextFindService(ITextFindService) | Overrides the default text find service with textFindService (e.g. a RegEx service).
 | TextFindService | A text finding service.


CanReplaceText Property

CanReplaceText Property
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider ► CanReplaceText
True if the text can be replaced, otherwise false.
Declaration Syntax
C# Visual Basic Visual C++
bool CanReplaceText { get; }
ReadOnly Property CanReplaceText As Boolean
property bool CanReplaceText {
    bool get ();
}


FindString Method (value, startIndex, comparisonType)

FindString Method (value, startIndex, comparisonType)
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider ► FindString(String, Int32, StringComparison)
Attemps to find value in the controls text.
Declaration Syntax
C# Visual Basic Visual C++
int FindString(
    string value,
    int startIndex,
    StringComparison comparisonType
)
Function FindString ( _
    value As String, _
    startIndex As Integer, _
    comparisonType As StringComparison _
) As Integer
int FindString(
    String^ value,
    int startIndex,
    StringComparison comparisonType
)
Parameters
value (String)

[Missing <param> documentation for "value"]

startIndex (Int32)

[Missing <param> documentation for "startIndex"]

comparisonType (StringComparison)

[Missing <param> documentation for "comparisonType"]

Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.IFindReplaceProvider.FindString(System.String,System.Int32,System.StringComparison)]


ReplaceString Method (value, startIndex, length)

ReplaceString Method (value, startIndex, length)
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider ► ReplaceString(String, Int32, Int32)
Replaces the text from startIndex for length characters with value.
Declaration Syntax
C# Visual Basic Visual C++
bool ReplaceString(
    string value,
    int startIndex,
    int length
)
Function ReplaceString ( _
    value As String, _
    startIndex As Integer, _
    length As Integer _
) As Boolean
bool ReplaceString(
    String^ value,
    int startIndex,
    int length
)
Parameters
value (String)
The new string.
startIndex (Int32)
the starting position.
length (Int32)
The length (0 implies an insert).
Return Value
True if successful, otherwise false.
See Also
CanReplaceText


SetTextFindService Method (textFindService)

SetTextFindService Method (textFindService)
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider ► SetTextFindService(ITextFindService)
Overrides the default text find service with textFindService (e.g. a RegEx service).
Declaration Syntax
C# Visual Basic Visual C++
void SetTextFindService(
    ITextFindService textFindService
)
Sub SetTextFindService ( _
    textFindService As ITextFindService _
)
void SetTextFindService(
    ITextFindService^ textFindService
)
Parameters
textFindService (ITextFindService)
The service to use.


TextFindService Property

TextFindService Property
Namespaces ► MiniSqlQuery.Core ► IFindReplaceProvider ► TextFindService
A text finding service.
Declaration Syntax
C# Visual Basic Visual C++
ITextFindService TextFindService { get; }
ReadOnly Property TextFindService As ITextFindService
property ITextFindService^ TextFindService {
    ITextFindService^ get ();
}
See Also
SetTextFindService(ITextFindService)


IHostWindow Interface

IHostWindow Interface
Namespaces ► MiniSqlQuery.Core ► IHostWindow
Core functions of the main MDI application host Form.
Declaration Syntax
C# Visual Basic Visual C++
public interface IHostWindow
Public Interface IHostWindow
public interface class IHostWindow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ActiveChildForm | A reference to the active child form.
 | AddPluginCommand<(Of <(TCommand>)>)()()() | Adds an ICommand to the plugins menu.
 | AddToolStripCommand<(Of <(TCommand>)>)(Nullable<(Of <(Int32>)>)) | Adds a command based button to the tool strip by index.
 | AddToolStripSeperator(Nullable<(Of <(Int32>)>)) | Adds a seperator to the tool strip by index.
 | DatabaseInspector | A reference to the database inspector window if open.
 | DisplayDockedForm(DockContent) | Displays the frm in the host window.
 | DisplayMessageBox(Form, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton, MessageBoxOptions, String, String) | Displays a message box with the specified text, caption, buttons, icon, default button, options, and Help button, using the specified Help file and Help keyword.
 | DisplaySimpleMessageBox(Form, String, String) | Displays an "OK" message box with the specified text and caption.
 | GetMenuItem(String) | Gets the relevent menu item by name.
 | Instance | The instance of the host form.
 | SetArguements(array<String>[]()[]) | A testable way to pass command line arguements to the application.
 | SetPointerState(Cursor) | Sets the application cursor to cursor.
 | SetStatus(Form, String) | Sets the status text of the host.
 | ShowDatabaseInspector(IDatabaseInspector, DockState) | Displays (and replaces if required) the database inspactor window.
 | ShowToolWindow(DockContent, DockState) | Displays a "tool" window, like the database inspector etc.
 | ToolStrip | Provides access to the host windows tool strip control.


ActiveChildForm Property

ActiveChildForm Property
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► ActiveChildForm
A reference to the active child form.
Declaration Syntax
C# Visual Basic Visual C++
Form ActiveChildForm { get; }
ReadOnly Property ActiveChildForm As Form
property Form^ ActiveChildForm {
    Form^ get ();
}
Value
The active form or null.


AddPluginCommand Method

AddPluginCommand<(Of <(TCommand>)>) Method
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► AddPluginCommand<(Of <(TCommand>)>)()()()
Adds an ICommand to the plugins menu.
Declaration Syntax
C# Visual Basic Visual C++
void AddPluginCommand<TCommand>() where TCommand : new(), ICommand
Sub AddPluginCommand(Of TCommand As {New, ICommand})
generic<typename TCommand>
where TCommand : gcnew(), ICommand
void AddPluginCommand()
Generic Template Parameters
TCommand
The command implementation to direct the name, image etc of the new menu item.


AddToolStripCommand Method (index)

AddToolStripCommand<(Of <(TCommand>)>) Method (index)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► AddToolStripCommand<(Of <(TCommand>)>)(Nullable<(Of <(Int32>)>))
Adds a command based button to the tool strip by index.
Declaration Syntax
C# Visual Basic Visual C++
void AddToolStripCommand<TCommand>(
    Nullable<int> index
) where TCommand : new(), ICommand
Sub AddToolStripCommand(Of TCommand As {New, ICommand}) ( _
    index As Nullable(Of Integer) _
)
generic<typename TCommand>
where TCommand : gcnew(), ICommand
void AddToolStripCommand(
    Nullable<int> index
)
Generic Template Parameters
TCommand
The command implementation to direct the name, image etc of the new tool strip item.
Parameters
index (Nullable <(Of <( Int32 >)>))
The position for the tool strip button, if null the item is appended to the end.


AddToolStripSeperator Method (index)

AddToolStripSeperator Method (index)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► AddToolStripSeperator(Nullable<(Of <(Int32>)>))
Adds a seperator to the tool strip by index.
Declaration Syntax
C# Visual Basic Visual C++
void AddToolStripSeperator(
    Nullable<int> index
)
Sub AddToolStripSeperator ( _
    index As Nullable(Of Integer) _
)
void AddToolStripSeperator(
    Nullable<int> index
)
Parameters
index (Nullable <(Of <( Int32 >)>))
The position for the seperator, if null the item is appended to the end.


DatabaseInspector Property

DatabaseInspector Property
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► DatabaseInspector
A reference to the database inspector window if open.
Declaration Syntax
C# Visual Basic Visual C++
IDatabaseInspector DatabaseInspector { get; }
ReadOnly Property DatabaseInspector As IDatabaseInspector
property IDatabaseInspector^ DatabaseInspector {
    IDatabaseInspector^ get ();
}
Value
A IDatabaseInspector object or null.


DisplayDockedForm Method (frm)

DisplayDockedForm Method (frm)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► DisplayDockedForm(DockContent)
Displays the frm in the host window.
Declaration Syntax
C# Visual Basic Visual C++
void DisplayDockedForm(
    DockContent frm
)
Sub DisplayDockedForm ( _
    frm As DockContent _
)
void DisplayDockedForm(
    DockContent^ frm
)
Parameters
frm (DockContent)
The child form to dock.


DisplayMessageBox Method (source, text, caption, buttons, icon, defaultButton, options, helpFilePath, keyword)

DisplayMessageBox Method (source, text, caption, buttons, icon, defaultButton, options, helpFilePath, keyword)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► DisplayMessageBox(Form, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton, MessageBoxOptions, String, String)
Displays a message box with the specified text, caption, buttons, icon, default button, options, and Help button, using the specified Help file and Help keyword.
Declaration Syntax
C# Visual Basic Visual C++
DialogResult DisplayMessageBox(
    Form source,
    string text,
    string caption,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton,
    MessageBoxOptions options,
    string helpFilePath,
    string keyword
)
Function DisplayMessageBox ( _
    source As Form, _
    text As String, _
    caption As String, _
    buttons As MessageBoxButtons, _
    icon As MessageBoxIcon, _
    defaultButton As MessageBoxDefaultButton, _
    options As MessageBoxOptions, _
    helpFilePath As String, _
    keyword As String _
) As DialogResult
DialogResult DisplayMessageBox(
    Form^ source,
    String^ text,
    String^ caption,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton,
    MessageBoxOptions options,
    String^ helpFilePath,
    String^ keyword
)
Parameters
source (Form)
The source form of the message.
text (String)
The text to display in the message box.
caption (String)
The text to display in the title bar of the message box.
buttons (MessageBoxButtons)
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon (MessageBoxIcon)
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultButton (MessageBoxDefaultButton)
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
options (MessageBoxOptions)
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.
helpFilePath (String)
The path and name of the Help file to display when the user clicks the Help button.
keyword (String)
The Help keyword to display when the user clicks the Help button.
Return Value
One of the DialogResult values.
Exceptions
Exception | Condition
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- The defaultButton specified is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.
ArgumentException | options specified both DefaultDesktopOnly and ServiceNotification.-or- buttons specified an invalid combination of MessageBoxButtons.


DisplaySimpleMessageBox Method (source, text, caption)

DisplaySimpleMessageBox Method (source, text, caption)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► DisplaySimpleMessageBox(Form, String, String)
Displays an "OK" message box with the specified text and caption.
Declaration Syntax
C# Visual Basic Visual C++
DialogResult DisplaySimpleMessageBox(
    Form source,
    string text,
    string caption
)
Function DisplaySimpleMessageBox ( _
    source As Form, _
    text As String, _
    caption As String _
) As DialogResult
DialogResult DisplaySimpleMessageBox(
    Form^ source,
    String^ text,
    String^ caption
)
Parameters
source (Form)
The source form of the message.
text (String)
The text to display in the message box.
caption (String)
The text to display in the title bar of the message box.
Return Value
One of the DialogResult values.


GetMenuItem Method (name)

GetMenuItem Method (name)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► GetMenuItem(String)
Gets the relevent menu item by name.
Declaration Syntax
C# Visual Basic Visual C++
ToolStripMenuItem GetMenuItem(
    string name
)
Function GetMenuItem ( _
    name As String _
) As ToolStripMenuItem
ToolStripMenuItem^ GetMenuItem(
    String^ name
)
Parameters
name (String)
The name of the menu to get, e.g. "Plugins" or "File" (no amphersand required).
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.IHostWindow.GetMenuItem(System.String)]


Instance Property

Instance Property
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► Instance
The instance of the host form.
Declaration Syntax
C# Visual Basic Visual C++
Form Instance { get; }
ReadOnly Property Instance As Form
property Form^ Instance {
    Form^ get ();
}


SetArguements Method (args)

SetArguements Method (args)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► SetArguements(array<String>[]()[])
A testable way to pass command line arguements to the application.
Declaration Syntax
C# Visual Basic Visual C++
void SetArguements(
    string[] args
)
Sub SetArguements ( _
    args As String() _
)
void SetArguements(
    array<String^>^ args
)
Parameters
args (array< String >[]()[])
An array of command line arguements.


SetPointerState Method (cursor)

SetPointerState Method (cursor)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► SetPointerState(Cursor)
Sets the application cursor to cursor.
Declaration Syntax
C# Visual Basic Visual C++
void SetPointerState(
    Cursor cursor
)
Sub SetPointerState ( _
    cursor As Cursor _
)
void SetPointerState(
    Cursor^ cursor
)
Parameters
cursor (Cursor)
The new cursor mode.


SetStatus Method (source, text)

SetStatus Method (source, text)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► SetStatus(Form, String)
Sets the status text of the host.
Declaration Syntax
C# Visual Basic Visual C++
void SetStatus(
    Form source,
    string text
)
Sub SetStatus ( _
    source As Form, _
    text As String _
)
void SetStatus(
    Form^ source,
    String^ text
)
Parameters
source (Form)
The source form, for tracking MDI children.
text (String)
The text to set.


ShowDatabaseInspector Method (DatabaseInspector, dockState)

ShowDatabaseInspector Method (DatabaseInspector, dockState)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► ShowDatabaseInspector(IDatabaseInspector, DockState)
Displays (and replaces if required) the database inspactor window.
Declaration Syntax
C# Visual Basic Visual C++
void ShowDatabaseInspector(
    IDatabaseInspector DatabaseInspector,
    DockState dockState
)
Sub ShowDatabaseInspector ( _
    DatabaseInspector As IDatabaseInspector, _
    dockState As DockState _
)
void ShowDatabaseInspector(
    IDatabaseInspector^ DatabaseInspector,
    DockState dockState
)
Parameters
DatabaseInspector (IDatabaseInspector)
The window to display.
dockState (DockState)
The state for the window.


ShowToolWindow Method (form, dockState)

ShowToolWindow Method (form, dockState)
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► ShowToolWindow(DockContent, DockState)
Displays a "tool" window, like the database inspector etc.
Declaration Syntax
C# Visual Basic Visual C++
void ShowToolWindow(
    DockContent form,
    DockState dockState
)
Sub ShowToolWindow ( _
    form As DockContent, _
    dockState As DockState _
)
void ShowToolWindow(
    DockContent^ form,
    DockState dockState
)
Parameters
form (DockContent)

[Missing <param> documentation for "form"]

dockState (DockState)

[Missing <param> documentation for "dockState"]


ToolStrip Property

ToolStrip Property
Namespaces ► MiniSqlQuery.Core ► IHostWindow ► ToolStrip
Provides access to the host windows tool strip control.
Declaration Syntax
C# Visual Basic Visual C++
ToolStrip ToolStrip { get; }
ReadOnly Property ToolStrip As ToolStrip
property ToolStrip^ ToolStrip {
    ToolStrip^ get ();
}
Value
The window tool strip.


ImageResource Class

ImageResource Class
Namespaces ► MiniSqlQuery.Core ► ImageResource
A strongly-typed resource class, for looking up localized strings, etc.
Declaration Syntax
C# Visual Basic Visual C++
public class ImageResource
Public Class ImageResource
public ref class ImageResource
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | accept |
 | around_text |
 | cancel |
 | cog |
 | cross |
 | Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
 | database |
 | database_add |
 | database_edit |
 | database_error |
 | database_refresh |
 | disk |
 | disk_multiple |
 | email |
 | email_go |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | find |
 | folder_page |
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | lightning |
 | MemberwiseClone()()() | (Inherited from Object.)
 | page |
 | page_white |
 | plugin |
 | plugin_go |
 | plugin_link |
 | ResourceManager | Returns the cached ResourceManager instance used by this class.
 | script |
 | script_code |
 | table_save |
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ImageResource


accept Property

accept Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► accept

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.accept]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap accept { get; }
Public Shared ReadOnly Property accept As Bitmap
public:
static property Bitmap^ accept {
    Bitmap^ get ();
}


around_text Property

around_text Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► around_text

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.around_text]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap around_text { get; }
Public Shared ReadOnly Property around_text As Bitmap
public:
static property Bitmap^ around_text {
    Bitmap^ get ();
}


cancel Property

cancel Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► cancel

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.cancel]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap cancel { get; }
Public Shared ReadOnly Property cancel As Bitmap
public:
static property Bitmap^ cancel {
    Bitmap^ get ();
}


cog Property

cog Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► cog

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.cog]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap cog { get; }
Public Shared ReadOnly Property cog As Bitmap
public:
static property Bitmap^ cog {
    Bitmap^ get ();
}


cross Property

cross Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► cross

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.cross]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap cross { get; }
Public Shared ReadOnly Property cross As Bitmap
public:
static property Bitmap^ cross {
    Bitmap^ get ();
}


Culture Property

Culture Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► Culture
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Declaration Syntax
C# Visual Basic Visual C++
public static CultureInfo Culture { get; set; }
Public Shared Property Culture As CultureInfo
public:
static property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}


database Property

database Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► database

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.database]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap database { get; }
Public Shared ReadOnly Property database As Bitmap
public:
static property Bitmap^ database {
    Bitmap^ get ();
}


database_add Property

database_add Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► database_add

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.database_add]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap database_add { get; }
Public Shared ReadOnly Property database_add As Bitmap
public:
static property Bitmap^ database_add {
    Bitmap^ get ();
}


database_edit Property

database_edit Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► database_edit

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.database_edit]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap database_edit { get; }
Public Shared ReadOnly Property database_edit As Bitmap
public:
static property Bitmap^ database_edit {
    Bitmap^ get ();
}


database_error Property

database_error Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► database_error

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.database_error]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap database_error { get; }
Public Shared ReadOnly Property database_error As Bitmap
public:
static property Bitmap^ database_error {
    Bitmap^ get ();
}


database_refresh Property

database_refresh Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► database_refresh

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.database_refresh]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap database_refresh { get; }
Public Shared ReadOnly Property database_refresh As Bitmap
public:
static property Bitmap^ database_refresh {
    Bitmap^ get ();
}


disk Property

disk Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► disk

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.disk]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap disk { get; }
Public Shared ReadOnly Property disk As Bitmap
public:
static property Bitmap^ disk {
    Bitmap^ get ();
}


disk_multiple Property

disk_multiple Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► disk_multiple

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.disk_multiple]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap disk_multiple { get; }
Public Shared ReadOnly Property disk_multiple As Bitmap
public:
static property Bitmap^ disk_multiple {
    Bitmap^ get ();
}


email Property

email Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► email

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.email]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap email { get; }
Public Shared ReadOnly Property email As Bitmap
public:
static property Bitmap^ email {
    Bitmap^ get ();
}


email_go Property

email_go Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► email_go

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.email_go]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap email_go { get; }
Public Shared ReadOnly Property email_go As Bitmap
public:
static property Bitmap^ email_go {
    Bitmap^ get ();
}


find Property

find Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► find

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.find]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap find { get; }
Public Shared ReadOnly Property find As Bitmap
public:
static property Bitmap^ find {
    Bitmap^ get ();
}


folder_page Property

folder_page Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► folder_page

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.folder_page]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap folder_page { get; }
Public Shared ReadOnly Property folder_page As Bitmap
public:
static property Bitmap^ folder_page {
    Bitmap^ get ();
}


lightning Property

lightning Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► lightning

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.lightning]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap lightning { get; }
Public Shared ReadOnly Property lightning As Bitmap
public:
static property Bitmap^ lightning {
    Bitmap^ get ();
}


page Property

page Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► page

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.page]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap page { get; }
Public Shared ReadOnly Property page As Bitmap
public:
static property Bitmap^ page {
    Bitmap^ get ();
}


page_white Property

page_white Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► page_white

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.page_white]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap page_white { get; }
Public Shared ReadOnly Property page_white As Bitmap
public:
static property Bitmap^ page_white {
    Bitmap^ get ();
}


plugin Property

plugin Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► plugin

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.plugin]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap plugin { get; }
Public Shared ReadOnly Property plugin As Bitmap
public:
static property Bitmap^ plugin {
    Bitmap^ get ();
}


plugin_go Property

plugin_go Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► plugin_go

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.plugin_go]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap plugin_go { get; }
Public Shared ReadOnly Property plugin_go As Bitmap
public:
static property Bitmap^ plugin_go {
    Bitmap^ get ();
}


plugin_link Property

plugin_link Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► plugin_link

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.plugin_link]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap plugin_link { get; }
Public Shared ReadOnly Property plugin_link As Bitmap
public:
static property Bitmap^ plugin_link {
    Bitmap^ get ();
}


ResourceManager Property

ResourceManager Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► ResourceManager
Returns the cached ResourceManager instance used by this class.
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceManager ResourceManager { get; }
Public Shared ReadOnly Property ResourceManager As ResourceManager
public:
static property ResourceManager^ ResourceManager {
    ResourceManager^ get ();
}


script Property

script Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► script

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.script]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap script { get; }
Public Shared ReadOnly Property script As Bitmap
public:
static property Bitmap^ script {
    Bitmap^ get ();
}


script_code Property

script_code Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► script_code

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.script_code]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap script_code { get; }
Public Shared ReadOnly Property script_code As Bitmap
public:
static property Bitmap^ script_code {
    Bitmap^ get ();
}


table_save Property

table_save Property
Namespaces ► MiniSqlQuery.Core ► ImageResource ► table_save

[Missing <summary> documentation for P:MiniSqlQuery.Core.ImageResource.table_save]

Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap table_save { get; }
Public Shared ReadOnly Property table_save As Bitmap
public:
static property Bitmap^ table_save {
    Bitmap^ get ();
}


INavigatableDocument Interface

INavigatableDocument Interface
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument
An interface for a "document" that can be navigated with a cursor, e.g. position at line 1, column 4 etc.
Declaration Syntax
C# Visual Basic Visual C++
public interface INavigatableDocument : ISupportCursorOffset
Public Interface INavigatableDocument _
    Implements ISupportCursorOffset
public interface class INavigatableDocument : ISupportCursorOffset
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CursorColumn | The current column the cursor is in.
 | CursorLine | The current line the cursor is on.
 | CursorOffset | Gets the cursor offset. (Inherited from ISupportCursorOffset.)
 | SetCursorByLocation(Int32, Int32) | Sets the cursor by line and column.
 | SetCursorByOffset(Int32) | Sets the cursor position by offset.
 | TotalLines | Gets the total number of lines in the editor.


CursorColumn Property

CursorColumn Property
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument ► CursorColumn
The current column the cursor is in.
Declaration Syntax
C# Visual Basic Visual C++
int CursorColumn { get; }
ReadOnly Property CursorColumn As Integer
property int CursorColumn {
    int get ();
}


CursorLine Property

CursorLine Property
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument ► CursorLine
The current line the cursor is on.
Declaration Syntax
C# Visual Basic Visual C++
int CursorLine { get; }
ReadOnly Property CursorLine As Integer
property int CursorLine {
    int get ();
}


SetCursorByLocation Method (line, column)

SetCursorByLocation Method (line, column)
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument ► SetCursorByLocation(Int32, Int32)
Sets the cursor by line and column.
Declaration Syntax
C# Visual Basic Visual C++
bool SetCursorByLocation(
    int line,
    int column
)
Function SetCursorByLocation ( _
    line As Integer, _
    column As Integer _
) As Boolean
bool SetCursorByLocation(
    int line,
    int column
)
Parameters
line (Int32)
The line.
column (Int32)
The column.
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.INavigatableDocument.SetCursorByLocation(System.Int32,System.Int32)]


SetCursorByOffset Method (offset)

SetCursorByOffset Method (offset)
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument ► SetCursorByOffset(Int32)
Sets the cursor position by offset.
Declaration Syntax
C# Visual Basic Visual C++
bool SetCursorByOffset(
    int offset
)
Function SetCursorByOffset ( _
    offset As Integer _
) As Boolean
bool SetCursorByOffset(
    int offset
)
Parameters
offset (Int32)
The offset.
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.INavigatableDocument.SetCursorByOffset(System.Int32)]


TotalLines Property

TotalLines Property
Namespaces ► MiniSqlQuery.Core ► INavigatableDocument ► TotalLines
Gets the total number of lines in the editor.
Declaration Syntax
C# Visual Basic Visual C++
int TotalLines { get; }
ReadOnly Property TotalLines As Integer
property int TotalLines {
    int get ();
}
Value
The total lines.


IPlugIn Interface

IPlugIn Interface
Namespaces ► MiniSqlQuery.Core ► IPlugIn
An interface for simple plugins for use in extending Mini SQL Query. Plugins are loaded from DLL's in the working directory matching the pattern "*.PlugIn.dll"
Declaration Syntax
C# Visual Basic Visual C++
public interface IPlugIn
Public Interface IPlugIn
public interface class IPlugIn
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializePlugIn()()() | Initializes the plug in, called after the main form is displayed.
 | LoadPlugIn(IApplicationServices) | Loads the plugin and stores a reference to the service container. Called at application startup time.
 | PluginDescription | A brief description of the plugin.
 | PluginName | The descriptive name of the plugin.
 | RequestedLoadOrder | Plugin load order. For external plugins start with values over 1000. This is a simple way of handling dependencies of other services etc.
 | UnloadPlugIn()()() | Called when the plugin is unloading (typically application shutdown).
Remarks

Plugins are created during the load process. After all plugins are loaded they are sorted by the RequestedLoadOrder property. Next the LoadPlugIn(IApplicationServices) method is called on each in turn supplying a reference to IApplicationServices. Next the main application form is displayed and after all control creation is complete (i.e. after the Form Shown event) a call to InitializePlugIn()()() is made for each loaded plugin. This is where ICommand instances should be created and assigned to buttons, menus etc. These services provide access to the rest of the editor. As the main form is closing down, each plugins UnloadPlugIn()()() method is called.

The PluginLoaderBase class can be used to handle the basics of a plugin class to speed development.


InitializePlugIn Method

InitializePlugIn Method
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► InitializePlugIn()()()
Initializes the plug in, called after the main form is displayed.
Declaration Syntax
C# Visual Basic Visual C++
void InitializePlugIn()
Sub InitializePlugIn
void InitializePlugIn()


LoadPlugIn Method (services)

LoadPlugIn Method (services)
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► LoadPlugIn(IApplicationServices)
Loads the plugin and stores a reference to the service container. Called at application startup time.
Declaration Syntax
C# Visual Basic Visual C++
void LoadPlugIn(
    IApplicationServices services
)
Sub LoadPlugIn ( _
    services As IApplicationServices _
)
void LoadPlugIn(
    IApplicationServices^ services
)
Parameters
services (IApplicationServices)
The service container, allows access to other serivces in the application.


PluginDescription Property

PluginDescription Property
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► PluginDescription
A brief description of the plugin.
Declaration Syntax
C# Visual Basic Visual C++
string PluginDescription { get; }
ReadOnly Property PluginDescription As String
property String^ PluginDescription {
    String^ get ();
}


PluginName Property

PluginName Property
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► PluginName
The descriptive name of the plugin.
Declaration Syntax
C# Visual Basic Visual C++
string PluginName { get; }
ReadOnly Property PluginName As String
property String^ PluginName {
    String^ get ();
}


RequestedLoadOrder Property

RequestedLoadOrder Property
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► RequestedLoadOrder
Plugin load order. For external plugins start with values over 1000. This is a simple way of handling dependencies of other services etc.
Declaration Syntax
C# Visual Basic Visual C++
int RequestedLoadOrder { get; }
ReadOnly Property RequestedLoadOrder As Integer
property int RequestedLoadOrder {
    int get ();
}


UnloadPlugIn Method

UnloadPlugIn Method
Namespaces ► MiniSqlQuery.Core ► IPlugIn ► UnloadPlugIn()()()
Called when the plugin is unloading (typically application shutdown).
Declaration Syntax
C# Visual Basic Visual C++
void UnloadPlugIn()
Sub UnloadPlugIn
void UnloadPlugIn()


IPrintableContent Interface

IPrintableContent Interface
Namespaces ► MiniSqlQuery.Core ► IPrintableContent
If implemented it signals that the class supports printing of the "contents" of the object.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPrintableContent
Public Interface IPrintableContent
public interface class IPrintableContent
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrintDocument | The document to print (or null if not supported in the current context).


PrintDocument Property

PrintDocument Property
Namespaces ► MiniSqlQuery.Core ► IPrintableContent ► PrintDocument
The document to print (or null if not supported in the current context).
Declaration Syntax
C# Visual Basic Visual C++
PrintDocument PrintDocument { get; }
ReadOnly Property PrintDocument As PrintDocument
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
}


IQueryEditor Interface

IQueryEditor Interface
Namespaces ► MiniSqlQuery.Core ► IQueryEditor
The functions of the editing window.
Declaration Syntax
C# Visual Basic Visual C++
public interface IQueryEditor : IFindReplaceProvider,
    INavigatableDocument, ISupportCursorOffset
Public Interface IQueryEditor _
    Implements IFindReplaceProvider, INavigatableDocument, ISupportCursorOffset
public interface class IQueryEditor : IFindReplaceProvider,
    INavigatableDocument, ISupportCursorOffset
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AllText | The contetnts of the editor.
 | CanReplaceText | True if the text can be replaced, otherwise false. (Inherited from IFindReplaceProvider.)
 | ClearSelection()()() | Clears the selection (deletes selected text if any).
 | CursorColumn | The current column the cursor is in. (Inherited from INavigatableDocument.)
 | CursorLine | The current line the cursor is on. (Inherited from INavigatableDocument.)
 | CursorOffset | Gets the cursor offset. (Inherited from ISupportCursorOffset.)
 | DataSet | The current data displayed in the result window.
 | EditorControl | Provides access to the actual editor control.
 | ExecuteQuery()()() | Executes the current query.
 | FileName | The filename of the docuemnt being edited (can be null, as in not saved yet).
 | FindString(String, Int32, StringComparison) | Attemps to find value in the controls text. (Inherited from IFindReplaceProvider.)
 | HighlightString(Int32, Int32) | Highlights the string starting at offset for length characters.
 | InsertText(String) | Inserts text at the current cursor position (selected text is overwritten).
 | IsBusy | True if a query is being executed.
 | IsDirty | True if the document has unsaved changes.
 | LoadFile()()() | Loads the file by the path in FileName.
 | ReplaceString(String, Int32, Int32) | Replaces the text from startIndex for length characters with value. (Inherited from IFindReplaceProvider.)
 | ResultsControl | Provides access to the actual results control, each tab contains a data grid view object.
 | SaveFile()()() | Saves the file by the path in FileName.
 | SelectedText | The currently selected text (if any) in the editor.
 | SetCursorByLocation(Int32, Int32) | Sets the cursor by line and column. (Inherited from INavigatableDocument.)
 | SetCursorByOffset(Int32) | Sets the cursor position by offset. (Inherited from INavigatableDocument.)
 | SetStatus(String) | Sets the "status" text for the form.
 | SetTextFindService(ITextFindService) | Overrides the default text find service with textFindService (e.g. a RegEx service). (Inherited from IFindReplaceProvider.)
 | TextFindService | A text finding service. (Inherited from IFindReplaceProvider.)
 | TotalLines | Gets the total number of lines in the editor. (Inherited from INavigatableDocument.)


AllText Property

AllText Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► AllText
The contetnts of the editor.
Declaration Syntax
C# Visual Basic Visual C++
string AllText { get; set; }
Property AllText As String
property String^ AllText {
    String^ get ();
    void set (String^ value);
}


ClearSelection Method

ClearSelection Method
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► ClearSelection()()()
Clears the selection (deletes selected text if any).
Declaration Syntax
C# Visual Basic Visual C++
void ClearSelection()
Sub ClearSelection
void ClearSelection()


DataSet Property

DataSet Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► DataSet
The current data displayed in the result window.
Declaration Syntax
C# Visual Basic Visual C++
DataSet DataSet { get; }
ReadOnly Property DataSet As DataSet
property DataSet^ DataSet {
    DataSet^ get ();
}


EditorControl Property

EditorControl Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► EditorControl
Provides access to the actual editor control.
Declaration Syntax
C# Visual Basic Visual C++
Control EditorControl { get; }
ReadOnly Property EditorControl As Control
property Control^ EditorControl {
    Control^ get ();
}


ExecuteQuery Method

ExecuteQuery Method
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► ExecuteQuery()()()
Executes the current query.
Declaration Syntax
C# Visual Basic Visual C++
void ExecuteQuery()
Sub ExecuteQuery
void ExecuteQuery()


FileName Property

FileName Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► FileName
The filename of the docuemnt being edited (can be null, as in not saved yet).
Declaration Syntax
C# Visual Basic Visual C++
string FileName { get; set; }
Property FileName As String
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


HighlightString Method (offset, length)

HighlightString Method (offset, length)
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► HighlightString(Int32, Int32)
Highlights the string starting at offset for length characters.
Declaration Syntax
C# Visual Basic Visual C++
void HighlightString(
    int offset,
    int length
)
Sub HighlightString ( _
    offset As Integer, _
    length As Integer _
)
void HighlightString(
    int offset,
    int length
)
Parameters
offset (Int32)
The offset to start at.
length (Int32)
The length.


InsertText Method (text)

InsertText Method (text)
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► InsertText(String)
Inserts text at the current cursor position (selected text is overwritten).
Declaration Syntax
C# Visual Basic Visual C++
void InsertText(
    string text
)
Sub InsertText ( _
    text As String _
)
void InsertText(
    String^ text
)
Parameters
text (String)

[Missing <param> documentation for "text"]


IsBusy Property

IsBusy Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► IsBusy
True if a query is being executed.
Declaration Syntax
C# Visual Basic Visual C++
bool IsBusy { get; }
ReadOnly Property IsBusy As Boolean
property bool IsBusy {
    bool get ();
}


IsDirty Property

IsDirty Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► IsDirty
True if the document has unsaved changes.
Declaration Syntax
C# Visual Basic Visual C++
bool IsDirty { get; }
ReadOnly Property IsDirty As Boolean
property bool IsDirty {
    bool get ();
}


LoadFile Method

LoadFile Method
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► LoadFile()()()
Loads the file by the path in FileName.
Declaration Syntax
C# Visual Basic Visual C++
void LoadFile()
Sub LoadFile
void LoadFile()


ResultsControl Property

ResultsControl Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► ResultsControl
Provides access to the actual results control, each tab contains a data grid view object.
Declaration Syntax
C# Visual Basic Visual C++
TabControl ResultsControl { get; }
ReadOnly Property ResultsControl As TabControl
property TabControl^ ResultsControl {
    TabControl^ get ();
}


SaveFile Method

SaveFile Method
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► SaveFile()()()
Saves the file by the path in FileName.
Declaration Syntax
C# Visual Basic Visual C++
void SaveFile()
Sub SaveFile
void SaveFile()


SelectedText Property

SelectedText Property
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► SelectedText
The currently selected text (if any) in the editor.
Declaration Syntax
C# Visual Basic Visual C++
string SelectedText { get; }
ReadOnly Property SelectedText As String
property String^ SelectedText {
    String^ get ();
}


SetStatus Method (text)

SetStatus Method (text)
Namespaces ► MiniSqlQuery.Core ► IQueryEditor ► SetStatus(String)
Sets the "status" text for the form.
Declaration Syntax
C# Visual Basic Visual C++
void SetStatus(
    string text
)
Sub SetStatus ( _
    text As String _
)
void SetStatus(
    String^ text
)
Parameters
text (String)
The message to appear in the status bar.


ISupportCursorOffset Interface

ISupportCursorOffset Interface
Namespaces ► MiniSqlQuery.Core ► ISupportCursorOffset
A "document" that supports reporting the position of it's cursor
Declaration Syntax
C# Visual Basic Visual C++
public interface ISupportCursorOffset
Public Interface ISupportCursorOffset
public interface class ISupportCursorOffset
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CursorOffset | Gets the cursor offset.


CursorOffset Property

CursorOffset Property
Namespaces ► MiniSqlQuery.Core ► ISupportCursorOffset ► CursorOffset
Gets the cursor offset.
Declaration Syntax
C# Visual Basic Visual C++
int CursorOffset { get; }
ReadOnly Property CursorOffset As Integer
property int CursorOffset {
    int get ();
}
Value
The cursor offset.


ITextFindService Interface

ITextFindService Interface
Namespaces ► MiniSqlQuery.Core ► ITextFindService
A text finding serice interface. A window can implement this interface and it will allow searching of its text.
Declaration Syntax
C# Visual Basic Visual C++
public interface ITextFindService
Public Interface ITextFindService
public interface class ITextFindService
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FindNext(FindTextRequest) | Finds the next string of text depending on the contrnts of the request.


FindNext Method (request)

FindNext Method (request)
Namespaces ► MiniSqlQuery.Core ► ITextFindService ► FindNext(FindTextRequest)
Finds the next string of text depending on the contrnts of the request.
Declaration Syntax
C# Visual Basic Visual C++
FindTextRequest FindNext(
    FindTextRequest request
)
Function FindNext ( _
    request As FindTextRequest _
) As FindTextRequest
FindTextRequest^ FindNext(
    FindTextRequest^ request
)
Parameters
request (FindTextRequest)
The request.
Return Value
A find request with position updated.


PlugInComparer Class

PlugInComparer Class
Namespaces ► MiniSqlQuery.Core ► PlugInComparer
Used for sorting plugins at load time.
Declaration Syntax
C# Visual Basic Visual C++
public class PlugInComparer : IComparer<IPlugIn>
Public Class PlugInComparer _
    Implements IComparer(Of IPlugIn)
public ref class PlugInComparer : IComparer<IPlugIn^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PlugInComparer()()() |
 | Compare(IPlugIn, IPlugIn) | Orders two plugin classes.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlugInComparer


PlugInComparer Constructor

PlugInComparer Constructor
Namespaces ► MiniSqlQuery.Core ► PlugInComparer ► PlugInComparer()()()
Initializes a new instance of the PlugInComparer class.
Declaration Syntax
C# Visual Basic Visual C++
public PlugInComparer()
Public Sub New
public:
PlugInComparer()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► MiniSqlQuery.Core ► PlugInComparer ► Compare(IPlugIn, IPlugIn)
Orders two plugin classes.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    IPlugIn x,
    IPlugIn y
)
Public Function Compare ( _
    x As IPlugIn, _
    y As IPlugIn _
) As Integer
public:
virtual int Compare(
    IPlugIn^ x,
    IPlugIn^ y
) sealed
Parameters
x (IPlugIn)

[Missing <param> documentation for "x"]

y (IPlugIn)

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.PlugInComparer.Compare(MiniSqlQuery.Core.IPlugIn,MiniSqlQuery.Core.IPlugIn)]

Remarks
This ordering functionality is a simple way of doing what Windsor does well, todo - convert to Windsor container for plugins!


PluginLoaderBase Class

PluginLoaderBase Class
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase
A simple base class to use for implementing the IPlugIn interface.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PluginLoaderBase : IPlugIn
Public MustInherit Class PluginLoaderBase _
    Implements IPlugIn
public ref class PluginLoaderBase abstract : IPlugIn
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginLoaderBase(String, String) | Creates a new instance of a plugin loader class.
 | PluginLoaderBase(String, String, Int32) | Creates a new instance of a plugin loader class.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | InitializePlugIn()()() | Must be implemented by the inheriting class. Called after the application has started.
 | LoadPlugIn(IApplicationServices) | Called when the plugins are loading during application startup. Stores the reference to services.
 | MemberwiseClone()()() | (Inherited from Object.)
 | PluginDescription | A brief description of the plugin.
 | PluginName | The descriptive name of the plugin.
 | RequestedLoadOrder | A lame ordering system. Needs to be replaced with Windsor containter etc.
 | Services | A reference to the applications service manager.
 | ToString()()() | (Inherited from Object.)
 | UnloadPlugIn()()() | Called as the application is shutting down.
Inheritance Hierarchy
Object
PluginLoaderBase


PluginLoaderBase Constructor

PluginLoaderBase Constructor
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► PluginLoaderBase()()()
Members
Icon | Member | Description
 | PluginLoaderBase(String, String) | Creates a new instance of a plugin loader class.
 | PluginLoaderBase(String, String, Int32) | Creates a new instance of a plugin loader class.


PluginLoaderBase Constructor (name, description)

PluginLoaderBase Constructor (name, description)
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► PluginLoaderBase(String, String)
Creates a new instance of a plugin loader class.
Declaration Syntax
C# Visual Basic Visual C++
public PluginLoaderBase(
    string name,
    string description
)
Public Sub New ( _
    name As String, _
    description As String _
)
public:
PluginLoaderBase(
    String^ name,
    String^ description
)
Parameters
name (String)
The descriptive name of the plugin
description (String)
A brief description of the plugin.
Remarks
The RequestedLoadOrder defaults to 1000.


PluginLoaderBase Constructor (name, description, requestedLoadOrder)

PluginLoaderBase Constructor (name, description, requestedLoadOrder)
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► PluginLoaderBase(String, String, Int32)
Creates a new instance of a plugin loader class.
Declaration Syntax
C# Visual Basic Visual C++
public PluginLoaderBase(
    string name,
    string description,
    int requestedLoadOrder
)
Public Sub New ( _
    name As String, _
    description As String, _
    requestedLoadOrder As Integer _
)
public:
PluginLoaderBase(
    String^ name,
    String^ description,
    int requestedLoadOrder
)
Parameters
name (String)
The descriptive name of the plugin
description (String)
A brief description of the plugin.
requestedLoadOrder (Int32)
The requested load order. See RequestedLoadOrder.


InitializePlugIn Method

InitializePlugIn Method
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► InitializePlugIn()()()
Must be implemented by the inheriting class. Called after the application has started.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void InitializePlugIn()
Public MustOverride Sub InitializePlugIn
public:
virtual void InitializePlugIn() abstract


LoadPlugIn Method (services)

LoadPlugIn Method (services)
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► LoadPlugIn(IApplicationServices)
Called when the plugins are loading during application startup. Stores the reference to services.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadPlugIn(
    IApplicationServices services
)
Public Sub LoadPlugIn ( _
    services As IApplicationServices _
)
public:
virtual void LoadPlugIn(
    IApplicationServices^ services
) sealed
Parameters
services (IApplicationServices)
The application services intance.


PluginDescription Property

PluginDescription Property
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► PluginDescription
A brief description of the plugin.
Declaration Syntax
C# Visual Basic Visual C++
public string PluginDescription { get; }
Public ReadOnly Property PluginDescription As String
public:
virtual property String^ PluginDescription {
    String^ get () sealed;
}


PluginName Property

PluginName Property
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► PluginName
The descriptive name of the plugin.
Declaration Syntax
C# Visual Basic Visual C++
public string PluginName { get; }
Public ReadOnly Property PluginName As String
public:
virtual property String^ PluginName {
    String^ get () sealed;
}


RequestedLoadOrder Property

RequestedLoadOrder Property
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► RequestedLoadOrder
A lame ordering system. Needs to be replaced with Windsor containter etc.
Declaration Syntax
C# Visual Basic Visual C++
public int RequestedLoadOrder { get; }
Public ReadOnly Property RequestedLoadOrder As Integer
public:
virtual property int RequestedLoadOrder {
    int get () sealed;
}


Services Property

Services Property
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► Services
A reference to the applications service manager.
Declaration Syntax
C# Visual Basic Visual C++
public IApplicationServices Services { get; }
Public ReadOnly Property Services As IApplicationServices
public:
property IApplicationServices^ Services {
    IApplicationServices^ get ();
}


UnloadPlugIn Method

UnloadPlugIn Method
Namespaces ► MiniSqlQuery.Core ► PluginLoaderBase ► UnloadPlugIn()()()
Called as the application is shutting down.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UnloadPlugIn()
Public Overridable Sub UnloadPlugIn
public:
virtual void UnloadPlugIn()
Remarks
In most cases there is probably no need to do anything here, all controls etc created will be disposed of implicitly. It would only be unmanaged references created explicitly by the plugin that would need removal or cleanup.


PlugInUtility Class

PlugInUtility Class
Namespaces ► MiniSqlQuery.Core ► PlugInUtility
Helper class for loading external plugins.
Declaration Syntax
C# Visual Basic Visual C++
public class PlugInUtility
Public Class PlugInUtility
public ref class PlugInUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PlugInUtility()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetInstances<(Of <(T>)>)(String, String) | Search baseDir for files that match the pattern searchPattern and return an array of instances.
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlugInUtility


PlugInUtility Constructor

PlugInUtility Constructor
Namespaces ► MiniSqlQuery.Core ► PlugInUtility ► PlugInUtility()()()
Initializes a new instance of the PlugInUtility class.
Declaration Syntax
C# Visual Basic Visual C++
public PlugInUtility()
Public Sub New
public:
PlugInUtility()


GetInstances Method (baseDir, searchPattern)

GetInstances<(Of <(T>)>) Method (baseDir, searchPattern)
Namespaces ► MiniSqlQuery.Core ► PlugInUtility ► GetInstances<(Of <(T>)>)(String, String)
Search baseDir for files that match the pattern searchPattern and return an array of instances.
Declaration Syntax
C# Visual Basic Visual C++
public static T[] GetInstances<T>(
    string baseDir,
    string searchPattern
)
Public Shared Function GetInstances(Of T) ( _
    baseDir As String, _
    searchPattern As String _
) As T()
public:
generic<typename T>
static array<T>^ GetInstances(
    String^ baseDir,
    String^ searchPattern
)
Generic Template Parameters
T
The type (interface or class) to find instances of.
Parameters
baseDir (String)
The search base.
searchPattern (String)
Search pattern, e.g. "*.dll".
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.PlugInUtility.GetInstances``1(System.String,System.String)]

Remarks
This is a simple way of doing what Windsor does well, todo - convert to Windsor container for plugins!


StringWriterWithEncoding Class

StringWriterWithEncoding Class
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding

[Missing <summary> documentation for T:MiniSqlQuery.Core.StringWriterWithEncoding]

Declaration Syntax
C# Visual Basic Visual C++
public class StringWriterWithEncoding : StringWriter
Public Class StringWriterWithEncoding _
    Inherits StringWriter
public ref class StringWriterWithEncoding : public StringWriter
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringWriterWithEncoding(Encoding) |
 | Close()()() | (Inherited from StringWriter.)
 | CoreNewLine | (Inherited from TextWriter.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Dispose(Boolean) | (Inherited from StringWriter.)
 | Dispose()()() | (Inherited from TextWriter.)
 | Encoding | (Overrides StringWriter.Encoding.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | Flush()()() | (Inherited from TextWriter.)
 | FormatProvider | (Inherited from TextWriter.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | GetStringBuilder()()() | (Inherited from StringWriter.)
 | GetType()()() | (Inherited from Object.)
 | InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | NewLine | (Inherited from TextWriter.)
 | ToString()()() | (Inherited from StringWriter.)
 | Write(Char) | (Inherited from StringWriter.)
 | Write(array<Char>[]()[], Int32, Int32) | (Inherited from StringWriter.)
 | Write(String) | (Inherited from StringWriter.)
 | Write(array<Char>[]()[]) | (Inherited from TextWriter.)
 | Write(Boolean) | (Inherited from TextWriter.)
 | Write(Int32) | (Inherited from TextWriter.)
 | Write(UInt32) | (Inherited from TextWriter.)
 | Write(Int64) | (Inherited from TextWriter.)
 | Write(UInt64) | (Inherited from TextWriter.)
 | Write(Single) | (Inherited from TextWriter.)
 | Write(Double) | (Inherited from TextWriter.)
 | Write(Decimal) | (Inherited from TextWriter.)
 | Write(Object) | (Inherited from TextWriter.)
 | Write(String, Object) | (Inherited from TextWriter.)
 | Write(String, Object, Object) | (Inherited from TextWriter.)
 | Write(String, Object, Object, Object) | (Inherited from TextWriter.)
 | Write(String, array<Object>[]()[]) | (Inherited from TextWriter.)
 | WriteLine()()() | (Inherited from TextWriter.)
 | WriteLine(Char) | (Inherited from TextWriter.)
 | WriteLine(array<Char>[]()[]) | (Inherited from TextWriter.)
 | WriteLine(array<Char>[]()[], Int32, Int32) | (Inherited from TextWriter.)
 | WriteLine(Boolean) | (Inherited from TextWriter.)
 | WriteLine(Int32) | (Inherited from TextWriter.)
 | WriteLine(UInt32) | (Inherited from TextWriter.)
 | WriteLine(Int64) | (Inherited from TextWriter.)
 | WriteLine(UInt64) | (Inherited from TextWriter.)
 | WriteLine(Single) | (Inherited from TextWriter.)
 | WriteLine(Double) | (Inherited from TextWriter.)
 | WriteLine(Decimal) | (Inherited from TextWriter.)
 | WriteLine(String) | (Inherited from TextWriter.)
 | WriteLine(Object) | (Inherited from TextWriter.)
 | WriteLine(String, Object) | (Inherited from TextWriter.)
 | WriteLine(String, Object, Object) | (Inherited from TextWriter.)
 | WriteLine(String, Object, Object, Object) | (Inherited from TextWriter.)
 | WriteLine(String, array<Object>[]()[]) | (Inherited from TextWriter.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | TextWriter
 |  |  | StringWriter
 |  |  |  | StringWriterWithEncoding


StringWriterWithEncoding Constructor (encoding)

StringWriterWithEncoding Constructor (encoding)
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► StringWriterWithEncoding(Encoding)
Initializes a new instance of the StringWriterWithEncoding class.
Declaration Syntax
C# Visual Basic Visual C++
public StringWriterWithEncoding(
    Encoding encoding
)
Public Sub New ( _
    encoding As Encoding _
)
public:
StringWriterWithEncoding(
    Encoding^ encoding
)
Parameters
encoding (Encoding)

[Missing <param> documentation for "encoding"]


Encoding Property

Encoding Property
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► Encoding

[Missing <summary> documentation for P:MiniSqlQuery.Core.StringWriterWithEncoding.Encoding]

Declaration Syntax
C# Visual Basic Visual C++
public override Encoding Encoding { get; }
Public Overrides ReadOnly Property Encoding As Encoding
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}


Utility Class

Utility Class
Namespaces ► MiniSqlQuery.Core ► Utility
Some basic helper functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Utility
Public NotInheritable Class Utility
public ref class Utility abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateConnectionStringsIfRequired()()() | Writes a default file if none present.
 | GetConnectionStringFilename()()() | Resolves the full filename of the connection string file, by default in the application data folder for "MiniSqlQuery", e.g. "C:\Users\(username)\AppData\Roaming\MiniSqlQuery\connections.txt". Allows for the override vis the "MiniSqlQuery.Core.dll.config" file "DefaultConnectionDefinitionFilename" setting.
 | GetOldConnectionStringFilename()()() |
 | GetSqlProviderNames()()() | Returns an array of SQL provider types supported by the current platform.
 | LoadConnectionDefinitionStrings()()() | Loads the connection definition file as an array of strings (can contain blanks and comments).
 | LoadConnections()()() | Loads the connection string data from the file.
 | LoadDbConnectionDefinitions()()() |
 | SaveConnections(String) | Saves the data to the connection string file.
 | SaveConnectionXml(String) |
 | ToXml<(Of <(T>)>)(T) | Serializes the obj.
Inheritance Hierarchy
Object
Utility


CreateConnectionStringsIfRequired Method

CreateConnectionStringsIfRequired Method
Namespaces ► MiniSqlQuery.Core ► Utility ► CreateConnectionStringsIfRequired()()()
Writes a default file if none present.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateConnectionStringsIfRequired()
Public Shared Sub CreateConnectionStringsIfRequired
public:
static void CreateConnectionStringsIfRequired()


GetConnectionStringFilename Method

GetConnectionStringFilename Method
Namespaces ► MiniSqlQuery.Core ► Utility ► GetConnectionStringFilename()()()
Resolves the full filename of the connection string file, by default in the application data folder for "MiniSqlQuery", e.g. "C:\Users\(username)\AppData\Roaming\MiniSqlQuery\connections.txt". Allows for the override vis the "MiniSqlQuery.Core.dll.config" file "DefaultConnectionDefinitionFilename" setting.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetConnectionStringFilename()
Public Shared Function GetConnectionStringFilename As String
public:
static String^ GetConnectionStringFilename()
Return Value
A filename.


GetOldConnectionStringFilename Method

GetOldConnectionStringFilename Method
Namespaces ► MiniSqlQuery.Core ► Utility ► GetOldConnectionStringFilename()()()

[Missing <summary> documentation for M:MiniSqlQuery.Core.Utility.GetOldConnectionStringFilename]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetOldConnectionStringFilename()
Public Shared Function GetOldConnectionStringFilename As String
public:
static String^ GetOldConnectionStringFilename()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.Utility.GetOldConnectionStringFilename]


GetSqlProviderNames Method

GetSqlProviderNames Method
Namespaces ► MiniSqlQuery.Core ► Utility ► GetSqlProviderNames()()()
Returns an array of SQL provider types supported by the current platform.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetSqlProviderNames()
Public Shared Function GetSqlProviderNames As String()
public:
static array<String^>^ GetSqlProviderNames()
Return Value
An array of SQL provider types.


LoadConnectionDefinitionStrings Method

LoadConnectionDefinitionStrings Method
Namespaces ► MiniSqlQuery.Core ► Utility ► LoadConnectionDefinitionStrings()()()
Loads the connection definition file as an array of strings (can contain blanks and comments).
Declaration Syntax
C# Visual Basic Visual C++
public static string[] LoadConnectionDefinitionStrings()
Public Shared Function LoadConnectionDefinitionStrings As String()
public:
static array<String^>^ LoadConnectionDefinitionStrings()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.Utility.LoadConnectionDefinitionStrings]

Remarks

Below is the default example of a connection definition file (See DefaultConnectionDefinitionFile()()()):

CopyC#
# Connection Definition file
# This file is intentionally plain text, thats nice and simple  :)
# Blank and Hashed (#) lines are ignored by the application. See more details at end of file.

Default - MSSQL Master@localhost   ^ System.Data.SqlClient ^ Server=.; Database=master; Integrated Security=SSPI
Sample MSSQL Northwind SQL Express ^ System.Data.SqlClient ^ Server=.\sqlexpress; Database=Northwind; Integrated Security=SSPI
Sample Access DB Connection        ^ System.Data.OleDb     ^ Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\SomeDirectory\access.mdb

######################################################################################################
#
# The format of a "connection definition" is "<Friendly Name>^<Provider Name>^<Connection String>"
# You can have whitespace around the "^" to aid readability etc.
# Typical providers:
#   System.Data.SqlClient
#   System.Data.Oracle
#   System.Data.OleDb
#   System.Data.Odbc
#


LoadConnections Method

LoadConnections Method
Namespaces ► MiniSqlQuery.Core ► Utility ► LoadConnections()()()
Loads the connection string data from the file.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoadConnections()
Public Shared Function LoadConnections As String
public:
static String^ LoadConnections()
Return Value
The text file contents as a single string.
See Also
GetConnectionStringFilename()()()


LoadDbConnectionDefinitions Method

LoadDbConnectionDefinitions Method
Namespaces ► MiniSqlQuery.Core ► Utility ► LoadDbConnectionDefinitions()()()

[Missing <summary> documentation for M:MiniSqlQuery.Core.Utility.LoadDbConnectionDefinitions]

Declaration Syntax
C# Visual Basic Visual C++
public static DbConnectionDefinitionList LoadDbConnectionDefinitions()
Public Shared Function LoadDbConnectionDefinitions As DbConnectionDefinitionList
public:
static DbConnectionDefinitionList^ LoadDbConnectionDefinitions()
Return Value

[Missing <returns> documentation for M:MiniSqlQuery.Core.Utility.LoadDbConnectionDefinitions]


SaveConnections Method (data)

SaveConnections Method (data)
Namespaces ► MiniSqlQuery.Core ► Utility ► SaveConnections(String)
Saves the data to the connection string file.
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveConnections(
    string data
)
Public Shared Sub SaveConnections ( _
    data As String _
)
public:
static void SaveConnections(
    String^ data
)
Parameters
data (String)
The contents of the file.
See Also
GetConnectionStringFilename()()()


SaveConnectionXml Method (xml)

SaveConnectionXml Method (xml)
Namespaces ► MiniSqlQuery.Core ► Utility ► SaveConnectionXml(String)

[Missing <summary> documentation for M:MiniSqlQuery.Core.Utility.SaveConnectionXml(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void SaveConnectionXml(
    string xml
)
Public Shared Sub SaveConnectionXml ( _
    xml As String _
)
public:
static void SaveConnectionXml(
    String^ xml
)
Parameters
xml (String)

[Missing <param> documentation for "xml"]


ToXml Method (obj)

ToXml<(Of <(T>)>) Method (obj)
Namespaces ► MiniSqlQuery.Core ► Utility ► ToXml<(Of <(T>)>)(T)
Serializes the obj.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToXml<T>(
    T obj
)
Public Shared Function ToXml(Of T) ( _
    obj As T _
) As String
public:
generic<typename T>
static String^ ToXml(
    T obj
)
Generic Template Parameters
T
The type.
Parameters
obj (T)
The object to serialize.
Return Value
A UTF8 XML string representing obj.


MiniSqlQuery.Core.Commands Namespace

MiniSqlQuery.Core.Commands Namespace
Namespaces ► MiniSqlQuery.Core.Commands
Helper classes for application commands.
Declaration Syntax
C# Visual Basic Visual C++
namespace MiniSqlQuery.Core.Commands
Namespace MiniSqlQuery.Core.Commands
namespace MiniSqlQuery.Core.Commands
Types
All Types Classes
Icon | Type | Description
 | CommandBase | A basic implementation of the ICommand interface. Represents a "command", typically a user action such as saving a file or executing a query. Inheritors must implement the abstract method Execute()()().


CommandBase Class

CommandBase Class
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase
A basic implementation of the ICommand interface. Represents a "command", typically a user action such as saving a file or executing a query. Inheritors must implement the abstract method Execute()()().
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CommandBase : ICommand
Public MustInherit Class CommandBase _
    Implements ICommand
public ref class CommandBase abstract : ICommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandBase(String) | Initializes a new instance of the CommandBase class. The default value for Enabled is true, and ShortcutKeys is Keys.None.
 | ActiveFormAsEditor | Attempts to convert the current host windows active form to IQueryEditor.
 | Enabled | Gets a value indicating whether this ICommand is enabled.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()() | Executes the command based on the current settings (abstract).
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Name | The name of the command, used in menus and buttons.
 | Services | A reference to the application services to allow access to the other components.
 | ShortcutKeys | Gets the menu shortcut keys for this command (e.g. Keys.F5).
 | SmallImage | Gets the "small image" associated with this control (for use on buttons or menu items). Use null (or Nothing in Visual Basic) if there is no image.
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CommandBase


CommandBase Constructor (name)

CommandBase Constructor (name)
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► CommandBase(String)
Initializes a new instance of the CommandBase class. The default value for Enabled is true, and ShortcutKeys is Keys.None.
Declaration Syntax
C# Visual Basic Visual C++
public CommandBase(
    string name
)
Public Sub New ( _
    name As String _
)
public:
CommandBase(
    String^ name
)
Parameters
name (String)
The name.


ActiveFormAsEditor Property

ActiveFormAsEditor Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► ActiveFormAsEditor
Attempts to convert the current host windows active form to IQueryEditor.
Declaration Syntax
C# Visual Basic Visual C++
protected IQueryEditor ActiveFormAsEditor { get; }
Protected ReadOnly Property ActiveFormAsEditor As IQueryEditor
protected:
property IQueryEditor^ ActiveFormAsEditor {
    IQueryEditor^ get ();
}
Value
A reference to the active query editor window, otherwise null.


Enabled Property

Enabled Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► Enabled
Gets a value indicating whether this ICommand is enabled.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Enabled { get; }
Public Overridable ReadOnly Property Enabled As Boolean
public:
virtual property bool Enabled {
    bool get ();
}
Value
true if enabled; otherwise, false (the default is true).


Execute Method

Execute Method
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► Execute()()()
Executes the command based on the current settings (abstract).
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Execute()
Public MustOverride Sub Execute
public:
virtual void Execute() abstract
Remarks
If a commands Enabled value is false, a call to Execute()()() should have no effect (and not throw an exception).


Name Property

Name Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► Name
The name of the command, used in menus and buttons.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Name { get; protected set; }
Public Overridable Property Name As String
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name of the command.


Services Property

Services Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► Services
A reference to the application services to allow access to the other components.
Declaration Syntax
C# Visual Basic Visual C++
public IApplicationServices Services { get; set; }
Public Property Services As IApplicationServices
public:
virtual property IApplicationServices^ Services {
    IApplicationServices^ get () sealed;
    void set (IApplicationServices^ value) sealed;
}
Value
A reference to the IApplicationServices instance.


ShortcutKeys Property

ShortcutKeys Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► ShortcutKeys
Gets the menu shortcut keys for this command (e.g. Keys.F5).
Declaration Syntax
C# Visual Basic Visual C++
public virtual Keys ShortcutKeys { get; protected set; }
Public Overridable Property ShortcutKeys As Keys
public:
virtual property Keys ShortcutKeys {
    Keys get ();
    void set (Keys value);
}
Value
The shortcut keys for this command (the default is Keys.None).


SmallImage Property

SmallImage Property
Namespaces ► MiniSqlQuery.Core.Commands ► CommandBase ► SmallImage
Gets the "small image" associated with this control (for use on buttons or menu items). Use null (or Nothing in Visual Basic) if there is no image.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Image SmallImage { get; protected set; }
Public Overridable Property SmallImage As Image
public:
virtual property Image^ SmallImage {
    Image^ get ();
    void set (Image^ value);
}
Value
The small image representing this command (the default is null).


MiniSqlQuery.Core.Controls Namespace

MiniSqlQuery.Core.Controls Namespace
Namespaces ► MiniSqlQuery.Core.Controls
Some simple controls.
Declaration Syntax
C# Visual Basic Visual C++
namespace MiniSqlQuery.Core.Controls
Namespace MiniSqlQuery.Core.Controls
namespace MiniSqlQuery.Core.Controls
Types
All Types Classes
Icon | Type | Description
 | ExceptionControl | A basic control for displaying an unhandled exception.
 | PluginListControl | A simple control to display plugin details.


ExceptionControl Class

ExceptionControl Class
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl
A basic control for displaying an unhandled exception.
Declaration Syntax
C# Visual Basic Visual C++
public class ExceptionControl : UserControl
Public Class ExceptionControl _
    Inherits UserControl
public ref class ExceptionControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExceptionControl()()() | Initializes a new instance of the ExceptionControl class.
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | ActiveControl | (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | AutoScaleDimensions | (Inherited from ContainerControl.)
 | AutoScaleFactor | (Inherited from ContainerControl.)
 | AutoScaleMode | (Inherited from ContainerControl.)
 | AutoScroll | (Inherited from ScrollableControl.)
 | AutoScrollMargin | (Inherited from ScrollableControl.)
 | AutoScrollMinSize | (Inherited from ScrollableControl.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoScrollPosition | (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | (Inherited from UserControl.)
 | AutoValidate | (Inherited from UserControl.)
 | AutoValidateChanged | (Inherited from UserControl.)
 | BackColor | (Inherited from Control.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from Control.)
 | BackgroundImageLayoutChanged | (Inherited from Control.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from UserControl.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()() | (Inherited from Control.)
 | CanEnableIme | (Inherited from ContainerControl.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()() | (Inherited from Control.)
 | CreateControl()()() | (Inherited from Control.)
 | CreateControlsInstance()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()() | (Inherited from Control.)
 | CreateHandle()()() | (Inherited from Control.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DockPadding | (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from Control.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()() | (Inherited from Component.)
 | FindForm()()() | (Inherited from Control.)
 | Focus()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from Control.)
 | ForeColorChanged | (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()() | (Inherited from Control.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetScrollState(Int32) | (Inherited from ScrollableControl.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()() | (Inherited from Control.)
 | GetType()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()() | (Inherited from Control.)
 | HorizontalScroll | (Inherited from ScrollableControl.)
 | HScroll | (Inherited from ScrollableControl.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase()()() | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()() | (Inherited from Control.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from Control.)
 | IsMirrored | (Inherited from Control.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | Load | (Inherited from UserControl.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()() | (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from Control.)
 | OnMouseLeave(EventArgs) | (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | (Inherited from Control.)
 | PaddingChanged | (Inherited from Control.)
 | Paint | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | ParentForm | (Inherited from ContainerControl.)
 | PerformAutoScale()()() | (Inherited from ContainerControl.)
 | PerformLayout()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | (Inherited from ContainerControl.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RecreateHandle()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | Refresh()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()() | (Inherited from Control.)
 | ResetBindings()()() | (Inherited from Control.)
 | ResetCursor()()() | (Inherited from Control.)
 | ResetFont()()() | (Inherited from Control.)
 | ResetForeColor()()() | (Inherited from Control.)
 | ResetImeMode()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()() | (Inherited from Control.)
 | ResetRightToLeft()()() | (Inherited from Control.)
 | ResetText()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()() | (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()() | (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetException(Exception) | Sets the exception to display.
 | SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | StyleChanged | (Inherited from Control.)
 | SuspendLayout()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | (Inherited from Control.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()() | (Inherited from Component.)
 | Update()()() | (Inherited from Control.)
 | UpdateBounds()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateDefaultButton()()() | (Inherited from ContainerControl.)
 | UpdateStyles()()() | (Inherited from Control.)
 | UpdateZOrder()()() | (Inherited from Control.)
 | UseWaitCursor | (Inherited from Control.)
 | Validate()()() | (Inherited from ContainerControl.)
 | Validate(Boolean) | (Inherited from ContainerControl.)
 | ValidateChildren()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | VerticalScroll | (Inherited from ScrollableControl.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | VScroll | (Inherited from ScrollableControl.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | ExceptionControl


ExceptionControl Constructor

ExceptionControl Constructor
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► ExceptionControl()()()
Initializes a new instance of the ExceptionControl class.
Declaration Syntax
C# Visual Basic Visual C++
public ExceptionControl()
Public Sub New
public:
ExceptionControl()


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


SetException Method (exp)

SetException Method (exp)
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► SetException(Exception)
Sets the exception to display.
Declaration Syntax
C# Visual Basic Visual C++
public void SetException(
    Exception exp
)
Public Sub SetException ( _
    exp As Exception _
)
public:
void SetException(
    Exception^ exp
)
Parameters
exp (Exception)
The exception object.


PluginListControl Class

PluginListControl Class
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl
A simple control to display plugin details.
Declaration Syntax
C# Visual Basic Visual C++
public class PluginListControl : UserControl
Public Class PluginListControl _
    Inherits UserControl
public ref class PluginListControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginListControl()()() | Initializes a new instance of the PluginListControl class.
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | ActiveControl | (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | AutoScaleDimensions | (Inherited from ContainerControl.)
 | AutoScaleFactor | (Inherited from ContainerControl.)
 | AutoScaleMode | (Inherited from ContainerControl.)
 | AutoScroll | (Inherited from ScrollableControl.)
 | AutoScrollMargin | (Inherited from ScrollableControl.)
 | AutoScrollMinSize | (Inherited from ScrollableControl.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoScrollPosition | (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | (Inherited from UserControl.)
 | AutoValidate | (Inherited from UserControl.)
 | AutoValidateChanged | (Inherited from UserControl.)
 | BackColor | (Inherited from Control.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from Control.)
 | BackgroundImageLayoutChanged | (Inherited from Control.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from UserControl.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()() | (Inherited from Control.)
 | CanEnableIme | (Inherited from ContainerControl.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()() | (Inherited from Control.)
 | CreateControl()()() | (Inherited from Control.)
 | CreateControlsInstance()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()() | (Inherited from Control.)
 | CreateHandle()()() | (Inherited from Control.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DockPadding | (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from Control.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()() | (Inherited from Component.)
 | FindForm()()() | (Inherited from Control.)
 | Focus()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from Control.)
 | ForeColorChanged | (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()() | (Inherited from Control.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetScrollState(Int32) | (Inherited from ScrollableControl.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()() | (Inherited from Control.)
 | GetType()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()() | (Inherited from Control.)
 | HorizontalScroll | (Inherited from ScrollableControl.)
 | HScroll | (Inherited from ScrollableControl.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase()()() | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()() | (Inherited from Control.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from Control.)
 | IsMirrored | (Inherited from Control.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | Load | (Inherited from UserControl.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()() | (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from Control.)
 | OnMouseLeave(EventArgs) | (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | (Inherited from Control.)
 | PaddingChanged | (Inherited from Control.)
 | Paint | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | ParentForm | (Inherited from ContainerControl.)
 | PerformAutoScale()()() | (Inherited from ContainerControl.)
 | PerformLayout()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | (Inherited from ContainerControl.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RecreateHandle()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | Refresh()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()() | (Inherited from Control.)
 | ResetBindings()()() | (Inherited from Control.)
 | ResetCursor()()() | (Inherited from Control.)
 | ResetFont()()() | (Inherited from Control.)
 | ResetForeColor()()() | (Inherited from Control.)
 | ResetImeMode()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()() | (Inherited from Control.)
 | ResetRightToLeft()()() | (Inherited from Control.)
 | ResetText()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()() | (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()() | (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetDataSource(array<IPlugIn>[]()[]) | Sets the data source to the plugins.
 | SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | StyleChanged | (Inherited from Control.)
 | SuspendLayout()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | (Inherited from Control.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()() | (Inherited from Component.)
 | Update()()() | (Inherited from Control.)
 | UpdateBounds()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateDefaultButton()()() | (Inherited from ContainerControl.)
 | UpdateStyles()()() | (Inherited from Control.)
 | UpdateZOrder()()() | (Inherited from Control.)
 | UseWaitCursor | (Inherited from Control.)
 | Validate()()() | (Inherited from ContainerControl.)
 | Validate(Boolean) | (Inherited from ContainerControl.)
 | ValidateChildren()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | VerticalScroll | (Inherited from ScrollableControl.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | VScroll | (Inherited from ScrollableControl.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | PluginListControl


PluginListControl Constructor

PluginListControl Constructor
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► PluginListControl()()()
Initializes a new instance of the PluginListControl class.
Declaration Syntax
C# Visual Basic Visual C++
public PluginListControl()
Public Sub New
public:
PluginListControl()


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


SetDataSource Method (plugins)

SetDataSource Method (plugins)
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► SetDataSource(array<IPlugIn>[]()[])
Sets the data source to the plugins.
Declaration Syntax
C# Visual Basic Visual C++
public void SetDataSource(
    IPlugIn[] plugins
)
Public Sub SetDataSource ( _
    plugins As IPlugIn() _
)
public:
void SetDataSource(
    array<IPlugIn^>^ plugins
)
Parameters
plugins (array< IPlugIn >[]()[])
The plugins to display.


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► AccessibilityNotifyClients()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |


BeginInvoke Method

BeginInvoke Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► BeginInvoke()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[]) |


Dispose Method

Dispose Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()() |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► GetChildAtPoint()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |


Invalidate Method

Invalidate Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Invalidate()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |


Invoke Method

Invoke Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Invoke()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[]) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()() |


PerformLayout Method

PerformLayout Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► PerformLayout()()()
Members
Icon | Member | Description
 | PerformLayout()()() |
 | PerformLayout(Control, String) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► ResumeLayout()()()
Members
Icon | Member | Description
 | ResumeLayout()()() |
 | ResumeLayout(Boolean) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► RtlTranslateAlignment()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |


Scale Method

Scale Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Scale()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |


Select Method

Select Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Select()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()() |


SetBounds Method

SetBounds Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► SetBounds()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |


UpdateBounds Method

UpdateBounds Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► UpdateBounds()()()
Members
Icon | Member | Description
 | UpdateBounds()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |


Validate Method

Validate Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► Validate()()()
Members
Icon | Member | Description
 | Validate()()() |
 | Validate(Boolean) |


ValidateChildren Method

ValidateChildren Method
Namespaces ► MiniSqlQuery.Core.Controls ► ExceptionControl ► ValidateChildren()()()
Members
Icon | Member | Description
 | ValidateChildren()()() | (Overrides ContainerControl.ValidateChildren()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► AccessibilityNotifyClients()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |


BeginInvoke Method

BeginInvoke Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► BeginInvoke()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[]) |


Dispose Method

Dispose Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()() |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► GetChildAtPoint()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |


Invalidate Method

Invalidate Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Invalidate()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |


Invoke Method

Invoke Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Invoke()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[]) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()() |


PerformLayout Method

PerformLayout Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► PerformLayout()()()
Members
Icon | Member | Description
 | PerformLayout()()() |
 | PerformLayout(Control, String) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► ResumeLayout()()()
Members
Icon | Member | Description
 | ResumeLayout()()() |
 | ResumeLayout(Boolean) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► RtlTranslateAlignment()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |


Scale Method

Scale Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Scale()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |


Select Method

Select Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Select()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()() |


SetBounds Method

SetBounds Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► SetBounds()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |


UpdateBounds Method

UpdateBounds Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► UpdateBounds()()()
Members
Icon | Member | Description
 | UpdateBounds()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |


Validate Method

Validate Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► Validate()()()
Members
Icon | Member | Description
 | Validate()()() |
 | Validate(Boolean) |


ValidateChildren Method

ValidateChildren Method
Namespaces ► MiniSqlQuery.Core.Controls ► PluginListControl ► ValidateChildren()()()
Members
Icon | Member | Description
 | ValidateChildren()()() | (Overrides ContainerControl.ValidateChildren()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


Dispose Method

Dispose Method
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides TextWriter.Dispose(Boolean).)
 | Dispose()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()() |


Write Method

Write Method
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► Write()()()
Members
Icon | Member | Description
 | Write(Char) | (Overrides TextWriter.Write(Char).)
 | Write(array<Char>[]()[], Int32, Int32) | (Overrides TextWriter.Write(array<Char>[]()[], Int32, Int32).)
 | Write(String) | (Overrides TextWriter.Write(String).)
 | Write(array<Char>[]()[]) |
 | Write(Boolean) |
 | Write(Int32) |
 | Write(UInt32) |
 | Write(Int64) |
 | Write(UInt64) |
 | Write(Single) |
 | Write(Double) |
 | Write(Decimal) |
 | Write(Object) |
 | Write(String, Object) |
 | Write(String, Object, Object) |
 | Write(String, Object, Object, Object) |
 | Write(String, array<Object>[]()[]) |


WriteLine Method

WriteLine Method
Namespaces ► MiniSqlQuery.Core ► StringWriterWithEncoding ► WriteLine()()()
Members
Icon | Member | Description
 | WriteLine()()() |
 | WriteLine(Char) |
 | WriteLine(array<Char>[]()[]) |
 | WriteLine(array<Char>[]()[], Int32, Int32) |
 | WriteLine(Boolean) |
 | WriteLine(Int32) |
 | WriteLine(UInt32) |
 | WriteLine(Int64) |
 | WriteLine(UInt64) |
 | WriteLine(Single) |
 | WriteLine(Double) |
 | WriteLine(Decimal) |
 | WriteLine(String) |
 | WriteLine(Object) |
 | WriteLine(String, Object) |
 | WriteLine(String, Object, Object) |
 | WriteLine(String, Object, Object, Object) |
 | WriteLine(String, array<Object>[]()[]) |


Namespaces

Namespaces
Namespaces
Mini SQL Query tool from PK Software.
Namespaces
Namespace | Description
MiniSqlQuery.Core | Mini SQL Query application interfaces and some basic implementations.
MiniSqlQuery.Core.Commands | Helper classes for application commands.
MiniSqlQuery.Core.Controls | Some simple controls.